Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Text shaping library" |
| 2 | DESCRIPTION = "HarfBuzz is an OpenType text shaping engine." |
| 3 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/HarfBuzz" |
| 4 | BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=HarfBuzz" |
| 5 | SECTION = "libs" |
| 6 | LICENSE = "MIT" |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=e11f5c3149cdec4bb309babb020b32b9 \ |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 8 | file://src/hb-ucd.cc;beginline=1;endline=15;md5=29d4dcb6410429195df67efe3382d8bc" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 9 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 10 | SRC_URI = "http://www.freedesktop.org/software/harfbuzz/release/${BP}.tar.xz" |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 11 | SRC_URI[md5sum] = "89b758a2eb14d56a94406cf914b62388" |
| 12 | SRC_URI[sha256sum] = "c651fb3faaa338aeb280726837c2384064cdc17ef40539228d88a1260960844f" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 13 | |
| 14 | inherit autotools pkgconfig lib_package gtk-doc |
| 15 | |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame] | 16 | PACKAGECONFIG ??= "cairo fontconfig freetype glib icu" |
| 17 | PACKAGECONFIG[cairo] = "--with-cairo,--without-cairo,cairo" |
| 18 | PACKAGECONFIG[fontconfig] = "--with-fontconfig,--without-fontconfig,fontconfig" |
| 19 | PACKAGECONFIG[freetype] = "--with-freetype,--without-freetype,freetype" |
| 20 | PACKAGECONFIG[glib] = "--with-glib,--without-glib,glib-2.0" |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 21 | PACKAGECONFIG[graphite] = "--with-graphite2,--without-graphite2,graphite2" |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame] | 22 | PACKAGECONFIG[icu] = "--with-icu,--without-icu,icu" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 23 | |
Brad Bishop | 1d80a2e | 2019-11-15 16:35:03 -0500 | [diff] [blame^] | 24 | PACKAGES =+ "${PN}-icu ${PN}-icu-dev ${PN}-subset" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 25 | |
| 26 | LEAD_SONAME = "libharfbuzz.so" |
| 27 | |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame] | 28 | do_install_append() { |
| 29 | # If no tools are installed due to PACKAGECONFIG then this directory is |
| 30 | #still installed, so remove it to stop packaging wanings. |
| 31 | rmdir --ignore-fail-on-non-empty ${D}${bindir} |
| 32 | } |
| 33 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 34 | FILES_${PN}-icu = "${libdir}/libharfbuzz-icu.so.*" |
| 35 | FILES_${PN}-icu-dev = "${libdir}/libharfbuzz-icu.la \ |
| 36 | ${libdir}/libharfbuzz-icu.so \ |
| 37 | ${libdir}/pkgconfig/harfbuzz-icu.pc \ |
| 38 | " |
Brad Bishop | 1d80a2e | 2019-11-15 16:35:03 -0500 | [diff] [blame^] | 39 | FILES_${PN}-subset = "${libdir}/libharfbuzz-subset.so.*" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 40 | |
| 41 | BBCLASSEXTEND = "native nativesdk" |