blob: 834d8154eecb1a7d364b6ba60e86e72dc229fd1a [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "OpenGL function pointer management library"
Brad Bishop1d80a2e2019-11-15 16:35:03 -05002DESCRIPTION = "It hides the complexity of dlopen(), dlsym(), \
3glXGetProcAddress(), eglGetProcAddress(), etc. from the app developer, with \
4very little knowledge needed on their part. They get to read GL specs and \
5write code using undecorated function names like glCompileShader()."
Brad Bishop19323692019-04-05 15:28:33 -04006HOMEPAGE = "https://github.com/anholt/libepoxy/"
7SECTION = "libs"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=58ef4c80d401e07bd9ee8b6b58cf464b"
11
12SRC_URI = "https://github.com/anholt/${BPN}/releases/download/${PV}/${BP}.tar.xz \
13 "
14SRC_URI[md5sum] = "e2845de8d2782b2d31c01ae8d7cd4cbb"
15SRC_URI[sha256sum] = "002958c5528321edd53440235d3c44e71b5b1e09b9177e8daf677450b6c4433d"
16UPSTREAM_CHECK_URI = "https://github.com/anholt/libepoxy/releases"
17
18inherit meson pkgconfig distro_features_check
19
20REQUIRED_DISTRO_FEATURES = "opengl"
21REQUIRED_DISTRO_FEATURES_class-native = ""
22REQUIRED_DISTRO_FEATURES_class-nativesdk = ""
23
24PACKAGECONFIG[egl] = "-Degl=yes, -Degl=no, virtual/egl"
Brad Bishopa34c0302019-09-23 22:34:48 -040025PACKAGECONFIG[x11] = "-Dglx=yes, -Dglx=no -Dx11=false, virtual/libx11 virtual/libgl"
Brad Bishop19323692019-04-05 15:28:33 -040026PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} egl"
27
28EXTRA_OEMESON += "-Dtests=false"
29
Brad Bishop79641f22019-09-10 07:20:22 -040030PACKAGECONFIG_class-native = "egl x11"
31PACKAGECONFIG_class-nativesdk = "egl x11"
Brad Bishop19323692019-04-05 15:28:33 -040032
33BBCLASSEXTEND = "native nativesdk"
34
35# This will ensure that dlopen will attempt only GL libraries provided by host
36do_install_append_class-native() {
37 chrpath --delete ${D}${libdir}/*.so
38}
39
40do_install_append_class-nativesdk() {
41 chrpath --delete ${D}${libdir}/*.so
42}