blob: 57a3024ea960e3b002a4c88b1943b726c05c8b49 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Custom Matchbox session files"
Brad Bishop1d80a2e2019-11-15 16:35:03 -05002DESCRIPTION = "Very simple session manager for matchbox tools"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05003HOMEPAGE = "http://www.matchbox-project.org/"
4BUGTRACKER = "http://bugzilla.yoctoproject.org/"
5
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://matchbox-session;endline=20;md5=180f1c169a15d059a56c30094f6fb5ea"
8
9SECTION = "x11"
10RCONFLICTS_${PN} = "matchbox-common"
11
12SRC_URI = "file://matchbox-session"
13S = "${WORKDIR}"
14
15PR = "r4"
16
17inherit update-alternatives
18
19ALTERNATIVE_${PN} = "x-session-manager"
20ALTERNATIVE_TARGET[x-session-manager] = "${bindir}/matchbox-session"
21ALTERNATIVE_PRIORITY = "100"
22
23do_install() {
24 install -d ${D}/${bindir}
25 install -m 0755 ${S}/matchbox-session ${D}/${bindir}
26}