blob: 7f5f910d3d63aeea414216788339019d9825c8d3 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "An HTTP library implementation in C"
2HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4SECTION = "x11/gnome/libs"
5LICENSE = "LGPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
7
8DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 intltool-native libpsl"
9
10SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
11
12SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz \
13 file://0001-Do-not-enforce-no-introspection-when-cross-building.patch \
14 "
Brad Bishop1d80a2e2019-11-15 16:35:03 -050015SRC_URI[md5sum] = "42016d80ecae4cf8eb416631049a273a"
16SRC_URI[sha256sum] = "8308984f1eee1c4f8c113a9c1763b2b22d981bd811b0cc82a9f3f1aa63228779"
17
18CVE_PRODUCT = "libsoup"
Brad Bishopc342db32019-05-15 21:57:59 -040019
20S = "${WORKDIR}/libsoup-${PV}"
21
22inherit meson gettext pkgconfig upstream-version-is-even gobject-introspection gtk-doc
23
24# libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Disable by default.
25PACKAGECONFIG ??= ""
26PACKAGECONFIG[gnome] = "-Dgnome=true,-Dgnome=false"
27PACKAGECONFIG[gssapi] = "-Dgssapi=true,-Dgssapi=false,krb5"
28
29EXTRA_OEMESON_append = " -Dvapi=false"
30
Brad Bishop1d80a2e2019-11-15 16:35:03 -050031GTKDOC_MESON_OPTION = "gtk_doc"
Brad Bishopc342db32019-05-15 21:57:59 -040032
33# When built without gnome support, libsoup-2.4 will contain only one shared lib
34# and will therefore become subject to renaming by debian.bbclass. Prevent
35# renaming in order to keep the package name consistent regardless of whether
36# gnome support is enabled or disabled.
37DEBIAN_NOAUTONAME_${PN} = "1"
38
39# glib-networking is needed for SSL, proxies, etc.
40RRECOMMENDS_${PN} = "glib-networking"
Brad Bishopa34c0302019-09-23 22:34:48 -040041
42BBCLASSEXTEND = "native"