Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "RISC-V Open Source Supervisor Binary Interface (OpenSBI)" |
| 2 | DESCRIPTION = "OpenSBI aims to provide an open-source and extensible implementation of the RISC-V SBI specification for a platform specific firmware (M-mode) and a general purpose OS, hypervisor or bootloader (S-mode or HS-mode). OpenSBI implementation can be easily extended by RISC-V platform or System-on-Chip vendors to fit a particular hadware configuration." |
| 3 | LICENSE = "BSD-2-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING.BSD;md5=42dd9555eb177f35150cf9aa240b61e5" |
| 5 | |
| 6 | require opensbi-payloads.inc |
| 7 | |
| 8 | inherit autotools-brokensep deploy |
| 9 | |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 10 | SRCREV = "a98258d0b537a295f517bbc8d813007336731fa9" |
| 11 | SRC_URI = "git://github.com/riscv/opensbi.git;branch=master \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | file://0001-Makefile-Don-t-specify-mabi-or-march.patch \ |
| 13 | " |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | EXTRA_OEMAKE += "PLATFORM=${RISCV_SBI_PLAT} I=${D}" |
| 18 | # If RISCV_SBI_PAYLOAD is set then include it as a payload |
| 19 | EXTRA_OEMAKE_append = " ${@riscv_get_extra_oemake_image(d)}" |
| 20 | |
| 21 | # Required if specifying a custom payload |
| 22 | do_compile[depends] += "${@riscv_get_do_compile_depends(d)}" |
| 23 | |
| 24 | do_install_append() { |
| 25 | # In the future these might be required as a dependency for other packages. |
| 26 | # At the moment just delete them to avoid warnings |
| 27 | rm -r ${D}/include |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 28 | rm -r ${D}/lib* |
| 29 | rm -r ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/payloads |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 30 | } |
| 31 | |
| 32 | do_deploy () { |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 33 | install -m 755 ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_payload.* ${DEPLOYDIR}/ |
| 34 | install -m 755 ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_jump.* ${DEPLOYDIR}/ |
| 35 | install -m 755 ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_dynamic.* ${DEPLOYDIR}/ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 36 | } |
| 37 | |
| 38 | addtask deploy before do_build after do_install |
| 39 | |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 40 | FILES_${PN} += "/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_jump.*" |
| 41 | FILES_${PN} += "/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_payload.*" |
| 42 | FILES_${PN} += "/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_dynamic.*" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 43 | |
| 44 | COMPATIBLE_HOST = "(riscv64|riscv32).*" |
| 45 | INHIBIT_PACKAGE_STRIP = "1" |
| 46 | |
| 47 | SECURITY_CFLAGS = "" |