Andrew Geissler | 4ed12e1 | 2020-06-05 18:00:41 -0500 | [diff] [blame] | 1 | SUMMARY = "Library for reading extended image information (EXIF) from JPEG files" |
| 2 | HOMEPAGE = "https://libexif.github.io/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "LGPLv2.1" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=243b725d71bb5df4a1e5920b344b86ad" |
| 6 | |
| 7 | def version_underscore(v): |
| 8 | return "_".join(v.split(".")) |
| 9 | |
| 10 | SRC_URI = "https://github.com/libexif/libexif/releases/download/libexif-${@version_underscore("${PV}")}-release/libexif-${PV}.tar.xz \ |
| 11 | " |
| 12 | |
| 13 | SRC_URI[sha256sum] = "5048f1c8fc509cc636c2f97f4b40c293338b6041a5652082d5ee2cf54b530c56" |
| 14 | |
| 15 | UPSTREAM_CHECK_URI = "https://github.com/libexif/libexif/releases/" |
| 16 | |
| 17 | inherit autotools gettext |
| 18 | |
| 19 | EXTRA_OECONF += "--disable-docs" |
Andrew Geissler | 635e0e4 | 2020-08-21 15:58:33 -0500 | [diff] [blame] | 20 | |
| 21 | BBCLASSEXTEND = "native nativesdk" |