blob: 0be1422a24fae341f07ee6794e88c2fe3e6aa7ba [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Build tools needed by external modules"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4
5inherit kernel-arch
6inherit pkgconfig
7
8PACKAGE_ARCH = "${MACHINE_ARCH}"
9
10S = "${WORKDIR}"
11
12do_configure[depends] += "virtual/kernel:do_shared_workdir openssl-native:do_populate_sysroot"
13do_compile[depends] += "virtual/kernel:do_compile_kernelmodules"
14
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050015RDEPENDS_${PN}-dev = ""
16
Brad Bishopf3fd2882019-06-21 08:06:37 -040017DEPENDS += "bc-native bison-native"
Brad Bishop316dfdd2018-06-25 12:45:53 -040018
19EXTRA_OEMAKE = " HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCPP="${BUILD_CPP}""
20
21# Build some host tools under work-shared. CC, LD, and AR are probably
22# not used, but this is the historical way of invoking "make scripts".
23#
24do_configure() {
25 unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
26 oe_runmake CC="${KERNEL_CC}" LD="${KERNEL_LD}" AR="${KERNEL_AR}" \
27 -C ${STAGING_KERNEL_DIR} O=${STAGING_KERNEL_BUILDDIR} scripts prepare
28
29}