blob: ec1df89a366a09d57c0e06ea8c9b3b4282b2eb92 [file] [log] [blame]
Matt Spinler1e3c4142016-08-12 12:52:36 -05001SUMMARY = "Phosphor OpenBMC machine readable workbook API modules"
2DESCRIPTION = "The API for the MRW XML generated by the Serverwiz tool"
3PR = "r1"
4
5S = "${WORKDIR}/scripts"
6
7inherit obmc-phosphor-license
8inherit native
9inherit perlnative
10inherit cpan-base
11
12DEPENDS += "libxml-simple-perl-native json-perl-native"
13
14SRC_URI += "git://github.com/open-power/serverwiz.git;subpath=scripts"
15SRCREV = "04f15f37e9ab6c09412a0abcffb87e9aefcc5368"
16
17do_install() {
18 install -d ${PERLLIBDIRS_class-native}/perl/site_perl/${PERLVERSION}/mrw
19 install -m 0755 Targets.pm ${PERLLIBDIRS_class-native}/perl/site_perl/${PERLVERSION}/mrw/Targets.pm
20}