Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | # |
| 2 | # Copyright (C) 2014 - 2017 Wind River Systems, Inc. |
| 3 | # |
| 4 | SUMMARY = "CFEngine is an IT infrastructure automation framework" |
| 5 | |
| 6 | DESCRIPTION = "CFEngine is an IT infrastructure automation framework \ |
| 7 | that helps engineers, system administrators and other stakeholders \ |
| 8 | in an IT system to manage and understand IT infrastructure throughout \ |
| 9 | its lifecycle. CFEngine takes systems from Build to Deploy, Manage and Audit." |
| 10 | |
| 11 | HOMEPAGE = "http://cfengine.com" |
| 12 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 13 | SKIP_RECIPE[cfengine] ?= "Needs porting to openssl 3.x" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 14 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 15 | LICENSE = "GPL-3.0-only" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 16 | LIC_FILES_CHKSUM = "file://LICENSE;md5=233aa25e53983237cf0bd4c238af255f" |
| 17 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 18 | DEPENDS += "attr tokyocabinet bison-native libxml2" |
| 19 | #RDEPENDS:cfengine += "attr tokyocabinet bison-native libxml2" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 20 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 21 | SRC_URI = "https://cfengine-package-repos.s3.amazonaws.com/tarballs/${BPN}-community-${PV}.tar.gz \ |
| 22 | file://0001-Fixed-with-libxml2-no-case-in-configure.ac.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 23 | file://set-path-of-default-config-file.patch \ |
| 24 | " |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 25 | #SRC_URI[md5sum] = "5318e40702bc66a3ece44ec4ad77712b" |
| 26 | SRC_URI[sha256sum] = "911778ddb0a4e03a3ddfc8fc0f033136e1551849ea2dcbdb3f0f14359dfe3126" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 27 | |
| 28 | inherit autotools-brokensep systemd |
| 29 | |
| 30 | export EXPLICIT_VERSION="${PV}" |
| 31 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 32 | SYSTEMD_SERVICE:${PN} = "cfengine3.service cf-apache.service cf-hub.service cf-postgres.service \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 33 | cf-runalerts.service cf-execd.service \ |
| 34 | cf-monitord.service cf-serverd.service \ |
| 35 | " |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 36 | SYSTEMD_AUTO_ENABLE:${PN} = "disable" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 37 | |
| 38 | PACKAGECONFIG ??= "libpcre openssl \ |
| 39 | ${@bb.utils.filter('DISTRO_FEATURES', 'pam systemd', d)} \ |
| 40 | " |
| 41 | PACKAGECONFIG[libxml2] = "--with-libxml2=yes,--with-libxml2=no,libxml2," |
| 42 | PACKAGECONFIG[mysql] = "--with-mysql=yes,--with-mysql=no,mysql," |
| 43 | PACKAGECONFIG[postgresql] = "--with-postgresql=yes,--with-postgresql=no,postgresql," |
| 44 | PACKAGECONFIG[acl] = "--with-libacl=yes,--with-libacl=no,acl," |
| 45 | PACKAGECONFIG[libvirt] = "--with-libvirt=yes,--with-libvirt=no,libvirt," |
| 46 | PACKAGECONFIG[libpcre] = "--with-pcre=yes,--with-pcre=no,libpcre," |
| 47 | PACKAGECONFIG[openssl] = "--with-openssl=yes,--with-openssl=no,openssl," |
| 48 | PACKAGECONFIG[pam] = "--with-pam=yes,--with-pam=no,libpam," |
| 49 | PACKAGECONFIG[libyaml] = "--with-libyaml,--without-libyaml,libyaml," |
| 50 | PACKAGECONFIG[systemd] = "--with-systemd-service=${systemd_system_unitdir},--without-systemd-service" |
| 51 | PACKAGECONFIG[libcurl] = "--with-libcurl,--without-libcurl,curl," |
| 52 | |
| 53 | EXTRA_OECONF = "hw_cv_func_va_copy=yes --with-init-script=${sysconfdir}/init.d --with-tokyocabinet" |
| 54 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 55 | do_install:append() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 56 | install -d ${D}${localstatedir}/${BPN}/bin |
| 57 | for f in `ls ${D}${bindir}`; do |
| 58 | ln -s ${bindir}/`basename $f` ${D}${localstatedir}/${BPN}/bin/ |
| 59 | done |
| 60 | |
| 61 | install -d ${D}${sysconfdir}/default |
| 62 | cat << EOF > ${D}${sysconfdir}/default/cfengine3 |
| 63 | RUN_CF_SERVERD=1 |
| 64 | RUN_CF_EXECD=1 |
| 65 | RUN_CF_MONITORD=1 |
| 66 | RUN_CF_HUB=0 |
| 67 | EOF |
| 68 | |
| 69 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then |
| 70 | install -m 0755 -D ${D}${sysconfdir}/init.d/cfengine3 ${D}${datadir}/${BPN}/cfengine3 |
| 71 | sed -i -e 's#/etc/init.d#${datadir}/${BPN}#' ${D}${systemd_system_unitdir}/*.service |
| 72 | fi |
| 73 | rm -rf ${D}${datadir}/cfengine/modules/packages/zypper |
| 74 | } |
| 75 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 76 | RDEPENDS:${PN} += "${BPN}-masterfiles" |