blob: 4bf34d879e8a381dc36e456f4796609f34ca2ea7 [file] [log] [blame]
Brad Bishop21f39fd2017-01-17 09:14:15 -05001SUMMARY = "Phosphor IPMI Inventory Plugin"
2DESCRIPTION = "A Phosphor IPMI plugin that updates inventory."
Brad Bishopcbac7fc2016-06-13 12:53:41 -04003DEPENDS += " \
Brad Bishop2f63e8c2017-01-28 13:00:52 -05004 virtual/phosphor-ipmi-fru-inventory \
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -06005 virtual/phosphor-ipmi-fru-properties \
Brad Bishopcbac7fc2016-06-13 12:53:41 -04006 systemd \
Deepak Kodihallic11cbc52017-02-16 07:50:37 -06007 sdbusplus \
Andrew Geissler35c7c072020-04-04 07:31:23 +00008 ${PYTHON_PN}-mako-native \
9 ${PYTHON_PN}-pyyaml-native \
Brad Bishopceb1c9a2017-01-17 10:07:14 -050010 phosphor-ipmi-host \
Matthew Barthfc77ec42016-10-19 16:00:49 -050011 autoconf-archive-native \
Patrick Venture5508db22018-10-16 19:50:55 -070012 phosphor-logging \
Patrick Venturee4ccd822019-03-26 11:07:32 -070013 cli11 \
Brad Bishopcbac7fc2016-06-13 12:53:41 -040014 "
Ed Tanous9936f862022-09-19 09:13:20 -070015PV = "1.0+git${SRCPV}"
16PR = "r1"
William A. Kennington III147a7952020-03-30 12:03:28 -070017
18SRC_URI += "file://of-name-to-eeprom.sh"
19
Patrick Williams12fc9392021-08-06 09:16:53 -050020SYSTEMD_SERVICE:${PN} += "obmc-read-eeprom@.service"
Chris Austen764ae432015-11-01 22:27:34 -060021S = "${WORKDIR}/git"
22
Ed Tanous9936f862022-09-19 09:13:20 -070023inherit autotools pkgconfig
24inherit obmc-phosphor-systemd
25inherit obmc-phosphor-ipmiprovider-symlink
26inherit phosphor-ipmi-fru
27inherit python3native
Brad Bishop2f63e8c2017-01-28 13:00:52 -050028
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -060029EXTRA_OECONF = " \
30 YAML_GEN=${STAGING_DIR_NATIVE}${config_datadir}/config.yaml \
Ratan Gupta338899a2017-03-30 14:32:02 +053031 PROP_YAML=${STAGING_DIR_NATIVE}${properties_datadir}/extra-properties.yaml \
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -060032 "
William A. Kennington III147a7952020-03-30 12:03:28 -070033
Patrick Williams12fc9392021-08-06 09:16:53 -050034do_install:append() {
William A. Kennington III147a7952020-03-30 12:03:28 -070035 install -d ${D}${bindir}
36 install -m 0755 ${WORKDIR}/of-name-to-eeprom.sh ${D}${bindir}
37}
Ed Tanous9936f862022-09-19 09:13:20 -070038
39RDEPENDS:${PN} += "bash"
40
41FILES:${PN} += "${bindir}/of-name-to-eeprom.sh"
42FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
43FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
44FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
45
46require ${BPN}.inc
47
48HOSTIPMI_PROVIDER_LIBRARY += "libstrgfnhandler.so"