Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "Google Authenticator PAM module" |
| 2 | HOME_PAGE = "https://github.com/google/google-authenticator-libpam" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | |
| 6 | SRC_URI = "git://github.com/google/google-authenticator-libpam.git;branch=master;protocol=https" |
| 7 | SRCREV = "962f353aac6cfc7b804547319db40f8b804f0b6c" |
| 8 | |
| 9 | DEPENDS = "libpam" |
| 10 | |
| 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | inherit autotools features_check |
| 14 | |
| 15 | REQUIRED_DISTRO_FEATURES = "pam" |
| 16 | |
| 17 | # Use the same dir location as PAM |
| 18 | EXTRA_OECONF = "--libdir=${base_libdir}" |
| 19 | |
| 20 | PACKAGES += "pam-google-authenticator" |
| 21 | FILES:pam-google-authenticator = "${base_libdir}/security/pam_google_authenticator.so" |
| 22 | |
| 23 | RDEPNEDS_pam-google-authenticator = "libpam" |