blob: e1ae65a67604a7187d340e2a4c656ea89f3d7697 [file] [log] [blame]
Brad Bishop5104c2f2016-08-30 00:46:40 -04001SUMMARY = "Phosphor DBUS to REST WSGI Application"
2DESCRIPTION = "Phosphor DBUS to REST WSGI Application."
Brad Bishop5ef5aa32015-10-27 17:13:26 -04003PR = "r1"
Brad Bishop5ef5aa32015-10-27 17:13:26 -04004
5inherit allarch
6inherit obmc-phosphor-systemd
7inherit setuptools
Ratan Guptadf7dfd42016-10-01 14:57:15 -05008inherit obmc-phosphor-discovery-service
Brad Bishop5ef5aa32015-10-27 17:13:26 -04009
Patrick Williamsa981b102017-03-01 21:25:36 -060010require phosphor-rest.inc
11
Dhruvaraj Subhashchandran1ea01342017-10-12 04:43:17 -050012RRECOMMENDS_${PN} += " \
13 virtual-obmc-wsgihost \
14 python-gevent-websocket \
15 "
Brad Bishop5104c2f2016-08-30 00:46:40 -040016
Brad Bishop5ef5aa32015-10-27 17:13:26 -040017RDEPENDS_${PN} += " \
18 python-xml \
19 python-dbus \
Brad Bishop12e3d602016-10-05 20:10:23 -040020 phosphor-mapper \
Brad Bishop18667542016-04-15 09:41:54 -040021 python-bottle \
22 python-spwd \
Brad Bishop376b0652016-08-29 21:47:04 -040023 pyphosphor-utils \
24 pyphosphor-dbus \
Brad Bishop5104c2f2016-08-30 00:46:40 -040025 pyphosphor-wsgi-apps-ns \
Tom Joseph20b50ef2018-09-03 22:08:21 -050026 pamela \
Brad Bishop5ef5aa32015-10-27 17:13:26 -040027 "
Nagaraju Gorugantib04fcb22018-06-01 00:19:42 -050028SRC_URI += "file://url_config.json \
29 "
30
31FILES_${PN}_append = " ${datadir}/rest-dbus/url_config.json"
Brad Bishop5ef5aa32015-10-27 17:13:26 -040032
Brad Bishop5104c2f2016-08-30 00:46:40 -040033S = "${WORKDIR}/git/module"
34SYSTEMD_SERVICE_${PN} = ""
35SYSTEMD_OVERRIDE_${PN} += "rest-dbus.conf:obmc-mapper.target.d/rest-dbus.conf"
36SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/wsgi_app"
Ratan Guptadf7dfd42016-10-01 14:57:15 -050037REGISTERED_SERVICES_${PN} += "phosphor_rest:tcp:443"
Nagaraju Gorugantib04fcb22018-06-01 00:19:42 -050038
39do_install_append(){
40 install -d ${D}${datadir}/rest-dbus
41 install -m 0644 -D ${WORKDIR}/url_config.json \
42 ${D}${datadir}/rest-dbus/url_config.json
43}