blob: 678ba9c4c838cd5fea23f40f230b6add1c2e90e9 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Javascript bindings for GNOME"
2LICENSE = "MIT & LGPLv2+"
3LIC_FILES_CHKSUM = " \
4 file://COPYING;md5=beb29cf17fabe736f0639b09ee6e76fa \
5 file://COPYING.LGPL;md5=3bf50002aefd002f49e7bb854063f7e7 \
6"
7
8GNOMEBASEBUILDCLASS = "autotools"
9
10DEPENDS = "mozjs gtk+3"
11
12inherit gnomebase gsettings gobject-introspection vala gettext features_check upstream-version-is-even
13
Andrew Geisslera2681d92020-10-16 10:17:07 -050014SRC_URI[archive.sha256sum] = "7fb3eb746c17363d9ee47f4a5d0bb048f0075611763eb0da11d85e0e57aff381"
Andrew Geisslere34f8962021-04-15 15:53:51 -050015SRC_URI += "file://0001-Disable-tests-on-host.patch \
16 file://0001-maint-Avoid-g_once_init_enter-error-in-GCC-11.patch \
17"
Andrew Geissler82c905d2020-04-13 13:39:40 -050018
19# gobject-introspection is mandatory and cannot be configured
20REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
21UNKNOWN_CONFIGURE_WHITELIST_append = " --enable-introspection --disable-introspection"
22
23EXTRA_OECONF = " \
24 --without-dbus-tests \
25 --disable-installed-tests \
26"
27
28do_configure_prepend() {
29 # make configure find gobject-introspection test code. Although we set
30 # --disable-installed-tests gjs builds them
31 sed -i 's|:$GI_DATADIR|:${STAGING_DIR_NATIVE}$GI_DATADIR|g' ${S}/configure.ac
32}
33
34FILES_${PN} += "${datadir}/gjs-1.0/lsan"
35
36PACKAGES =+ "${PN}-valgrind"
37FILES_${PN}-valgrind = "${datadir}/gjs-1.0/valgrind"
38RSEPENDS_${PN}-valgrind += "valgrind"