blob: dbb04ef8e38dd54febb74f355bd17a7689200296 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Javascript bindings for GNOME"
2LICENSE = "MIT & LGPLv2+"
3LIC_FILES_CHKSUM = " \
4 file://COPYING;md5=beb29cf17fabe736f0639b09ee6e76fa \
5 file://COPYING.LGPL;md5=3bf50002aefd002f49e7bb854063f7e7 \
6"
7
8GNOMEBASEBUILDCLASS = "autotools"
9
10DEPENDS = "mozjs gtk+3"
11
12inherit gnomebase gsettings gobject-introspection vala gettext features_check upstream-version-is-even
13
Andrew Geisslera2681d92020-10-16 10:17:07 -050014SRC_URI[archive.sha256sum] = "7fb3eb746c17363d9ee47f4a5d0bb048f0075611763eb0da11d85e0e57aff381"
Andrew Geissler82c905d2020-04-13 13:39:40 -050015SRC_URI += "file://0001-Disable-tests-on-host.patch"
16
17# gobject-introspection is mandatory and cannot be configured
18REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
19UNKNOWN_CONFIGURE_WHITELIST_append = " --enable-introspection --disable-introspection"
20
21EXTRA_OECONF = " \
22 --without-dbus-tests \
23 --disable-installed-tests \
24"
25
26do_configure_prepend() {
27 # make configure find gobject-introspection test code. Although we set
28 # --disable-installed-tests gjs builds them
29 sed -i 's|:$GI_DATADIR|:${STAGING_DIR_NATIVE}$GI_DATADIR|g' ${S}/configure.ac
30}
31
32FILES_${PN} += "${datadir}/gjs-1.0/lsan"
33
34PACKAGES =+ "${PN}-valgrind"
35FILES_${PN}-valgrind = "${datadir}/gjs-1.0/valgrind"
36RSEPENDS_${PN}-valgrind += "valgrind"