blob: 7403cf64f7f945c3e95f9c63333942eede9303f9 [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001SUMMARY = "A command line tool for updating and displaying info about boot loaders"
2DESCRIPTION = "grubby is a command line tool for updating and displaying information \
3about the configuration files for the grub, lilo, elilo (ia64), yaboot (powerpc) and \
4zipl (s390) boot loaders. It is primarily designed to be used from scripts which install \
5new kernels and need to find information about the current boot environment. \
6"
Brad Bishop316dfdd2018-06-25 12:45:53 -04007HOMEPAGE = "https://github.com/rhboot/grubby"
Patrick Williamsddad1a12017-02-23 20:36:32 -06008LICENSE = "GPLv2+"
9
10LIC_FILES_CHKSUM = "file://COPYING;md5=892f569a555ba9c07a568a7c0c4fa63a"
11
12DEPENDS = "popt util-linux"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050013DEPENDS_append_libc-musl = " libexecinfo"
Patrick Williamsddad1a12017-02-23 20:36:32 -060014
Brad Bishop316dfdd2018-06-25 12:45:53 -040015S = "${WORKDIR}/git"
16SRCREV = "79c5cfa02c567efdc5bb18cdd584789e2e35aa23"
17SRC_URI = "git://github.com/rhboot/grubby.git;protocol=https; \
Patrick Williamsddad1a12017-02-23 20:36:32 -060018 file://grubby-rename-grub2-editenv-to-grub-editenv.patch \
19 file://run-ptest \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050020 file://0001-Add-another-variable-LIBS-to-provides-libraries-from.patch \
21 file://0002-include-paths.h-for-_PATH_MOUNTED.patch \
22 "
Patrick Williamsddad1a12017-02-23 20:36:32 -060023
Patrick Williamsddad1a12017-02-23 20:36:32 -060024RDEPENDS_${PN} += "dracut"
25
26inherit autotools-brokensep ptest
27
Brad Bishopd7bf8c12018-02-25 22:55:05 -050028EXTRA_OEMAKE = "-e 'CC=${CC}' 'LDFLAGS=${LDFLAGS}' LIBS='${LIBS}'"
Patrick Williamsddad1a12017-02-23 20:36:32 -060029
Brad Bishopd7bf8c12018-02-25 22:55:05 -050030LIBS_libc-musl = "-lexecinfo"
31LIBS ?= ""
Patrick Williamsddad1a12017-02-23 20:36:32 -060032do_install_ptest() {
33 install -d ${D}${PTEST_PATH}
34 cp -r ${S}/test ${S}/test.sh ${D}${PTEST_PATH}
35 sed -i 's|./grubby|grubby|' ${D}${PTEST_PATH}/test.sh
36}
37
Brad Bishop90ca7472019-08-20 09:15:15 -040038RDEPENDS_${PN} += "bash"
Patrick Williamsddad1a12017-02-23 20:36:32 -060039RDEPENDS_${PN}-ptest = "util-linux-getopt bash"
40
41COMPATIBLE_HOST = '(x86_64.*|i.86.*)-(linux|freebsd.*)'