blob: 5a998248c8dd8e57109e473d6544393cded45dbc [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001SUMMARY = "A command line tool for updating and displaying info about boot loaders"
2DESCRIPTION = "grubby is a command line tool for updating and displaying information \
3about the configuration files for the grub, lilo, elilo (ia64), yaboot (powerpc) and \
4zipl (s390) boot loaders. It is primarily designed to be used from scripts which install \
5new kernels and need to find information about the current boot environment. \
6"
7LICENSE = "GPLv2+"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=892f569a555ba9c07a568a7c0c4fa63a"
10
11DEPENDS = "popt util-linux"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012DEPENDS_append_libc-musl = " libexecinfo"
Patrick Williamsddad1a12017-02-23 20:36:32 -060013
14SRC_URI = "https://github.com/rhinstaller/${BPN}/archive/${PV}-1.tar.gz;downloadfilename=${BPN}-${PV}-1.tar.gz \
15 file://grubby-rename-grub2-editenv-to-grub-editenv.patch \
16 file://run-ptest \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017 file://0001-Add-another-variable-LIBS-to-provides-libraries-from.patch \
18 file://0002-include-paths.h-for-_PATH_MOUNTED.patch \
19 "
Patrick Williamsddad1a12017-02-23 20:36:32 -060020
21SRC_URI[md5sum] = "1005907b275d6d93368d045274537d86"
22SRC_URI[sha256sum] = "85f1c678484f74c8978e8643451594967defce463a86c35cb1ee56d12767a9df"
23
24S = "${WORKDIR}/${BPN}-${PV}-1"
25
26RDEPENDS_${PN} += "dracut"
27
28inherit autotools-brokensep ptest
29
Brad Bishopd7bf8c12018-02-25 22:55:05 -050030EXTRA_OEMAKE = "-e 'CC=${CC}' 'LDFLAGS=${LDFLAGS}' LIBS='${LIBS}'"
Patrick Williamsddad1a12017-02-23 20:36:32 -060031
Brad Bishopd7bf8c12018-02-25 22:55:05 -050032LIBS_libc-musl = "-lexecinfo"
33LIBS ?= ""
Patrick Williamsddad1a12017-02-23 20:36:32 -060034do_install_ptest() {
35 install -d ${D}${PTEST_PATH}
36 cp -r ${S}/test ${S}/test.sh ${D}${PTEST_PATH}
37 sed -i 's|./grubby|grubby|' ${D}${PTEST_PATH}/test.sh
38}
39
40RDEPENDS_${PN}-ptest = "util-linux-getopt bash"
41
42COMPATIBLE_HOST = '(x86_64.*|i.86.*)-(linux|freebsd.*)'