blob: 8fe837b75cebb96a80104c5b27e03e6c90cb4876 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Graph Visualization Tools"
2HOMEPAGE = "http://www.graphviz.org"
3LICENSE = "EPL-1.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=9109f5fc16cf963fb3cdd32781b3ce04"
5
6DEPENDS = " \
7 intltool-native \
8 bison-native \
9 groff-native \
10 libtool \
11 gdk-pixbuf \
12 librsvg \
13 cairo \
14 pango \
15 expat \
16 freetype \
17"
18DEPENDS_append_class-target = " ${BPN}-native"
Andrew Geissler89770b02020-06-13 10:40:47 -050019DEPENDS_append_class-nativesdk = " ${BPN}-native"
Brad Bishop19323692019-04-05 15:28:33 -040020
21inherit autotools-brokensep pkgconfig gettext
22
Andrew Geissler4b7c1152020-11-30 19:55:29 -060023SRC_URI = "https://www2.graphviz.org/Packages/stable/portable_source/${BP}.tar.gz \
Brad Bishop26bdd442019-08-16 17:08:17 -040024 file://0001-plugin-pango-Include-freetype-headers-explicitly.patch \
Brad Bishop19323692019-04-05 15:28:33 -040025"
26# Use native mkdefs
Brad Bishop26bdd442019-08-16 17:08:17 -040027SRC_URI_append_class-target = "\
28 file://0001-Use-native-mkdefs.patch \
29 file://0001-Set-use_tcl-to-be-empty-string-if-tcl-is-disabled.patch \
30"
Andrew Geissler89770b02020-06-13 10:40:47 -050031SRC_URI_append_class-nativesdk = "\
32 file://0001-Use-native-mkdefs.patch \
33 file://graphviz-setup.sh \
34"
Andrew Geissler4b7c1152020-11-30 19:55:29 -060035SRC_URI[sha256sum] = "8e1b34763254935243ccdb83c6ce108f531876d7a5dfd443f255e6418b8ea313"
Brad Bishop19323692019-04-05 15:28:33 -040036
Andrew Geissler4b7c1152020-11-30 19:55:29 -060037EXTRA_OECONF_append = " PS2PDF=/bin/echo"
Brad Bishop19323692019-04-05 15:28:33 -040038
39EXTRA_OECONF_class-target = "\
40 --with-expatincludedir=${STAGING_INCDIR} \
41 --with-expatlibdir=${STAGING_LIBDIR} \
42 --without-included-ltdl \
43 --disable-java \
Brad Bishop26bdd442019-08-16 17:08:17 -040044 --disable-tcl \
Brad Bishop19323692019-04-05 15:28:33 -040045 --disable-r \
46 --disable-sharp \
47 "
Andrew Geissler89770b02020-06-13 10:40:47 -050048EXTRA_OECONF_class-nativesdk = "\
49 --with-expatincludedir=${STAGING_INCDIR} \
50 --with-expatlibdir=${STAGING_LIBDIR} \
51 --without-included-ltdl \
52 --disable-java \
53 --disable-tcl \
54 --disable-r \
55 --disable-sharp \
56 "
Brad Bishop19323692019-04-05 15:28:33 -040057CFLAGS_append_class-target = " -D_typ_ssize_t=1 -D_long_double=1"
Andrew Geissler89770b02020-06-13 10:40:47 -050058CFLAGS_append_class-nativesdk = " -D_typ_ssize_t=1 -D_long_double=1"
Brad Bishop19323692019-04-05 15:28:33 -040059do_configure_prepend() {
60 cd ${S}
61 # create version.m4 and ignore libtoolize errors
62 ./autogen.sh NOCONFIG || true
63}
64
65do_install_append_class-native() {
66 # install mkdefs for target build
67 install -m755 ${B}/lib/gvpr/mkdefs ${D}${bindir}
68}
69
Andrew Geissler89770b02020-06-13 10:40:47 -050070do_install_append_class-nativesdk() {
71 # graphviz-setup.sh must be executed at SDK installation
72 install -d ${D}${SDKPATHNATIVE}/post-relocate-setup.d
73 install -m 0755 ${WORKDIR}/graphviz-setup.sh ${D}${SDKPATHNATIVE}/post-relocate-setup.d
74}
75FILES_${PN}_class-nativesdk += "${SDKPATHNATIVE}"
76
Brad Bishop26bdd442019-08-16 17:08:17 -040077PACKAGES =+ "${PN}-python ${PN}-perl ${PN}-demo"
78
79FILES_${PN}-python += "${libdir}/python*/site-packages/ ${libdir}/graphviz/python/"
80FILES_${PN}-perl += "${libdir}/perl5/*/vendor_perl/ ${libdir}/graphviz/perl/"
81FILES_${PN}-demo += "${datadir}/graphviz/demo/"
82
83RDEPENDS_${PN}-perl += "perl"
Andrew Geissler82c905d2020-04-13 13:39:40 -050084RDEPENDS_${PN}-python += "python3"
85RDEPENDS_${PN}-demo += "python3 perl"
Brad Bishop26bdd442019-08-16 17:08:17 -040086
87INSANE_SKIP_${PN}-perl = "dev-so"
88INSANE_SKIP_${PN}-python = "dev-so"
89
Brad Bishop19323692019-04-05 15:28:33 -040090FILES_SOLIBSDEV_append = " ${libdir}/graphviz/lib*${SOLIBSDEV}"
91
Andrew Geissler89770b02020-06-13 10:40:47 -050092BBCLASSEXTEND = "native nativesdk"