blob: 176cf4498ae2c529a03326c0f35c65b05f55f2d0 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Graph Visualization Tools"
2HOMEPAGE = "http://www.graphviz.org"
3LICENSE = "EPL-1.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=9109f5fc16cf963fb3cdd32781b3ce04"
5
6DEPENDS = " \
7 intltool-native \
8 bison-native \
9 groff-native \
10 libtool \
11 gdk-pixbuf \
12 librsvg \
13 cairo \
14 pango \
15 expat \
16 freetype \
17"
18DEPENDS_append_class-target = " ${BPN}-native"
19
20inherit autotools-brokensep pkgconfig gettext
21
22# The source tarball suggested at
23# https://graphviz.gitlab.io/_pages/Download/Download_source.html has no
24# version in its name. So once graphviz is updgraded, only first time users will
25# get checksum errors. Fedora people seem to expect same so they use a versioned
26# source - see https://src.fedoraproject.org/cgit/rpms/graphviz.git/tree/graphviz.spec
27
28SRC_URI = "https://gitlab.com/graphviz/graphviz/-/archive/stable_release_${PV}/graphviz-stable_release_${PV}.tar.gz \
Brad Bishop26bdd442019-08-16 17:08:17 -040029 file://0001-plugin-pango-Include-freetype-headers-explicitly.patch \
Brad Bishop19323692019-04-05 15:28:33 -040030"
31# Use native mkdefs
Brad Bishop26bdd442019-08-16 17:08:17 -040032SRC_URI_append_class-target = "\
33 file://0001-Use-native-mkdefs.patch \
34 file://0001-Set-use_tcl-to-be-empty-string-if-tcl-is-disabled.patch \
35"
Brad Bishop19323692019-04-05 15:28:33 -040036SRC_URI[md5sum] = "2acf30ca8e6cc8b001b0334db65fd072"
37SRC_URI[sha256sum] = "e6c3f8dbfde1c4523055403927bef29f97f9fc12715c1042b5dcf648a2c1c62a"
38
39S = "${WORKDIR}/${BPN}-stable_release_${PV}"
40
41EXTRA_OECONF_class-target = "\
42 --with-expatincludedir=${STAGING_INCDIR} \
43 --with-expatlibdir=${STAGING_LIBDIR} \
44 --without-included-ltdl \
45 --disable-java \
Brad Bishop26bdd442019-08-16 17:08:17 -040046 --disable-tcl \
Brad Bishop19323692019-04-05 15:28:33 -040047 --disable-r \
48 --disable-sharp \
49 "
50CFLAGS_append_class-target = " -D_typ_ssize_t=1 -D_long_double=1"
51do_configure_prepend() {
52 cd ${S}
53 # create version.m4 and ignore libtoolize errors
54 ./autogen.sh NOCONFIG || true
55}
56
57do_install_append_class-native() {
58 # install mkdefs for target build
59 install -m755 ${B}/lib/gvpr/mkdefs ${D}${bindir}
60}
61
Brad Bishop26bdd442019-08-16 17:08:17 -040062PACKAGES =+ "${PN}-python ${PN}-perl ${PN}-demo"
63
64FILES_${PN}-python += "${libdir}/python*/site-packages/ ${libdir}/graphviz/python/"
65FILES_${PN}-perl += "${libdir}/perl5/*/vendor_perl/ ${libdir}/graphviz/perl/"
66FILES_${PN}-demo += "${datadir}/graphviz/demo/"
67
68RDEPENDS_${PN}-perl += "perl"
69RDEPENDS_${PN}-python += "python"
70RDEPENDS_${PN}-demo += "python perl"
71
72INSANE_SKIP_${PN}-perl = "dev-so"
73INSANE_SKIP_${PN}-python = "dev-so"
74
Brad Bishop19323692019-04-05 15:28:33 -040075FILES_SOLIBSDEV_append = " ${libdir}/graphviz/lib*${SOLIBSDEV}"
76
77BBCLASSEXTEND = "native"