blob: eb75699cc613fcbbf1448ad2b7b61516189afe2b [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "1-Wire file system"
2DESCRIPTION = "OWFS is an easy way to use the powerful 1-wire system of Dallas/Maxim"
3HOMEPAGE = "http://www.owfs.org/"
4SECTION = "console/network"
5
6LICENSE = "GPLv2 & LGPLv2"
Brad Bishop2d39a062019-10-28 08:33:36 -04007LIC_FILES_CHKSUM = "file://COPYING;md5=628b867016631792781a8735a04760e5 \
8 file://COPYING.LIB;md5=9021b7435efdd9fb22beef8291134099"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009
10DEPENDS = "fuse virtual/libusb0"
Brad Bishop2d39a062019-10-28 08:33:36 -040011# v3.2p3
12SRCREV = "3744375dfaa350e31c9b360eb1e1a517bbeb5c47"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013SRC_URI = "git://github.com/owfs/owfs \
Brad Bishop2d39a062019-10-28 08:33:36 -040014 file://0001-Add-build-rule-for-README.patch \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050015 file://0001-Fix-compilation-with-GCC10.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016 file://owhttpd \
17 file://owserver \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018 "
19
20S = "${WORKDIR}/git"
21
Brad Bishop19323692019-04-05 15:28:33 -040022inherit autotools-brokensep update-rc.d pkgconfig systemd
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023
24EXTRA_OECONF = " \
25 --with-fuseinclude=${STAGING_INCDIR} \
26 --with-fuselib=${STAGING_LIBDIR} \
27 --enable-owfs \
28 --enable-owhttpd \
29 --enable-w1 \
30 --disable-swig \
31 --disable-owtcl \
32 --disable-owphp \
33 --disable-owpython \
34 --disable-owperl \
35"
36
Patrick Williams213cb262021-08-07 19:21:33 -050037do_install:prepend() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080038 install -d ${D}${sysconfdir}/default/
39 install -d ${D}${sysconfdir}/init.d/
40 install -m 0755 ${WORKDIR}/owhttpd ${D}${sysconfdir}/init.d/owhttpd
41 install -m 0755 ${WORKDIR}/owserver ${D}${sysconfdir}/init.d/owserver
42}
43
44PACKAGES =+ "owftpd owhttpd owserver owshell libowcapi libow libownet owmon owtap"
45
Patrick Williams213cb262021-08-07 19:21:33 -050046DESCRIPTION:owftpd = "Anoymous FTP server for 1-wire access"
47DESCRIPTION:owhttpd = "Tiny webserver for 1-wire control"
48DESCRIPTION:owserver = "Backend server (daemon) for 1-wire control"
49DESCRIPTION:owshell = "owdir owread owwrite owpresent owget - lightweight owserver access"
50DESCRIPTION:libowcapi = "easy C-language 1-wire interface "
51DESCRIPTION:libow = "easy C-language 1-wire interface to the owserver protocol"
52DESCRIPTION:libownet = "easy C-language 1-wire interface to the owserver protocol"
53DESCRIPTION:owmon = "Monitor for owserver settings and statistics"
54DESCRIPTION:owtap = "Packet sniffer for the owserver protocol"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080055
Patrick Williams213cb262021-08-07 19:21:33 -050056FILES:owftpd = "${bindir}/owftpd ${systemd_system_unitdir}/owftpd.service"
57FILES:owhttpd = "${bindir}/owhttpd ${sysconfdir}/init.d/owhttpd \
Brad Bishop19323692019-04-05 15:28:33 -040058 ${systemd_system_unitdir}/owhttpd.service"
Patrick Williams213cb262021-08-07 19:21:33 -050059FILES:owserver = "${bindir}/owserver ${sysconfdir}/init.d/owserver \
Brad Bishop19323692019-04-05 15:28:33 -040060 ${systemd_system_unitdir}/owserver.service \
61 ${systemd_system_unitdir}/owserver.socket"
Patrick Williams213cb262021-08-07 19:21:33 -050062FILES:owshell = "${bindir}/owread ${bindir}/owwrite \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080063 ${bindir}/owdir ${bindir}/owpresent \
64 ${bindir}/owget ${bindir}/owside"
Patrick Williams213cb262021-08-07 19:21:33 -050065FILES:owmon = "${bindir}/owmon"
66FILES:owtap = "${bindir}/owtap"
67FILES:libowcapi = "${libdir}/libowcapi-*"
68FILES:libow = "${libdir}/libow-*"
69FILES:libownet = "${libdir}/libownet-*"
70FILES:${PN} += "${systemd_system_unitdir}/owfs.service"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080071
72INITSCRIPT_PACKAGES = "owhttpd owserver"
Patrick Williams213cb262021-08-07 19:21:33 -050073INITSCRIPT_NAME:owserver = "owserver"
74INITSCRIPT_NAME:owhttpd = "owhttpd"
75INITSCRIPT_PARAMS:owserver = "defaults 20"
76INITSCRIPT_PARAMS:owhttpd = "defaults 21"
Brad Bishop19323692019-04-05 15:28:33 -040077
Patrick Williams213cb262021-08-07 19:21:33 -050078SYSTEMD_SERVICE:${PN} = "owfs.service"
79SYSTEMD_SERVICE:${PN}-owftpd = "owftpd.service"
80SYSTEMD_SERVICE:${PN}-owhttpd = "owhttpd.service"
81SYSTEMD_SERVICE:${PN}-owserver = "owserver.service owserver.socket"