blob: 171e46eddba58fd99a6e243138bd214cbfcfb698 [file] [log] [blame]
Brad Bishop23eaf032019-11-20 05:15:02 -05001SUMMARY = "Window navigation construction toolkit"
2LICENSE = "LGPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
4
5GNOMEBASEBUILDCLASS = "meson"
6
Brad Bishop8410d612019-11-25 09:40:59 -05007inherit gnomebase gsettings gobject-introspection gettext features_check upstream-version-is-even
Brad Bishop23eaf032019-11-20 05:15:02 -05008
Brad Bishop23eaf032019-11-20 05:15:02 -05009DEPENDS = " \
10 colord \
11 geocode-glib \
12 gcr \
13 gnome-desktop3 \
14 libgweather \
15 lcms \
16 libcanberra \
17 geoclue \
18 libnotify \
19 upower \
20 libwacom \
21 virtual/libx11 \
22"
23
24# all these are mandatory
25REQUIRED_DISTRO_FEATURES = "x11 polkit pulseaudio systemd gobject-introspection-data"
Brad Bishop23eaf032019-11-20 05:15:02 -050026
Andrew Geissler89770b02020-06-13 10:40:47 -050027SRC_URI[archive.md5sum] = "102dc488a6a726e4050cf5ab7e967e8d"
28SRC_URI[archive.sha256sum] = "3e33dbd319b562a5ab602dcab6de3ca81b85f8346672e90ec632b36bbf15ee4b"
Brad Bishop23eaf032019-11-20 05:15:02 -050029
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050030UNKNOWN_CONFIGURE_WHITELIST = "introspection"
31
Brad Bishop23eaf032019-11-20 05:15:02 -050032PACKAGECONFIG ??= " \
33 cups nm \
34 alsa gudev \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050035 smartcard \
Brad Bishop23eaf032019-11-20 05:15:02 -050036 ${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)} \
37"
38PACKAGECONFIG[alsa] = "-Dalsa=true,-Dalsa=false,alsa-lib"
39PACKAGECONFIG[cups] = "-Dcups=true,-Dcups=false,cups"
40PACKAGECONFIG[gudev] = "-Dgudev=true,-Dgudev=false,libgudev"
41PACKAGECONFIG[nm] = "-Dnetwork_manager=true,-Dnetwork_manager=false,networkmanager"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050042PACKAGECONFIG[smartcard] = "-Dsmartcard=true,-Dsmartcard=false,nss"
Brad Bishop23eaf032019-11-20 05:15:02 -050043PACKAGECONFIG[wayland] = "-Dwayland=true,-Dwayland=false,wayland"
44
Patrick Williams213cb262021-08-07 19:21:33 -050045FILES:${PN} += " \
Brad Bishop23eaf032019-11-20 05:15:02 -050046 ${systemd_user_unitdir} \
47 ${libdir}/gnome-settings-daemon-3.0/libgsd.so \
48"