blob: ab7167c946340cb8a89df94957382cfd1d66ed58 [file] [log] [blame]
Andrew Geisslera2681d92020-10-16 10:17:07 -05001SUMMARY = "Open source iec61850 implementation"
2DESCRIPTION = "IEC 61850 is an international standard for \
3communication systems in Substation Automation Systems \
4(SAS) and management of Decentralized Energy Resources \
5(DER). It is seen as one of the communication standards \
6of the emerging Smart Grid. \
7The project libIEC61850 provides a server and client \
8library for the IEC 61850/MMS, IEC 61850/GOOSE and IEC \
961850-9-2/Sampled Values communication protocols \
10written in C. It is available under the GPLv3 license."
11HOMEPAGE = "http://libiec61850.com"
12SECTION = "console/network"
13LICENSE = "GPLv3"
14LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
15DEPENDS = "swig-native python3"
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070016SRCREV = "fcefc746fea286aeaa40d2f62240216da81c85e5"
Andrew Geisslera2681d92020-10-16 10:17:07 -050017
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070018SRC_URI = "git://github.com/mz-automation/${BPN}.git;branch=v1.5 \
19 file://0001-pyiec61850-don-t-break-CMAKE_INSTALL_PATH-by-trying-.patch \
Andrew Geisslera2681d92020-10-16 10:17:07 -050020"
21
22S = "${WORKDIR}/git"
23
24inherit cmake pkgconfig python3-dir python3native siteinfo
25
26EXTRA_OECMAKE = " \
27 -DBUILD_EXAMPLES=OFF \
28 -DBUILD_PYTHON_BINDINGS=ON \
29"
30
Patrick Williams213cb262021-08-07 19:21:33 -050031RDEPENDS:${PN}-python = " python3-core "
32RDEPENDS:${PN} = " python3-core "
Andrew Geisslera2681d92020-10-16 10:17:07 -050033
Patrick Williams213cb262021-08-07 19:21:33 -050034FILES:${PN} += " \
Andrew Geisslera2681d92020-10-16 10:17:07 -050035 ${libdir}/${PYTHON_DIR}/site-packages/iec61850.py \
36 ${libdir}/${PYTHON_DIR}/site-packages/_iec61850.so \
37"