blob: b62ed04ce69a63454fa57fb6dfe880010b636c01 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Lightweight crypto and SSL/TLS library"
2DESCRIPTION = "mbedtls is a lean open source crypto library \
3for providing SSL and TLS support in your programs. It offers \
4an intuitive API and documented header files, so you can actually \
5understand what the code does. It features: \
6 \
7 - Symmetric algorithms, like AES, Blowfish, Triple-DES, DES, ARC4, \
8 Camellia and XTEA \
9 - Hash algorithms, like SHA-1, SHA-2, RIPEMD-160 and MD5 \
10 - Entropy pool and random generators, like CTR-DRBG and HMAC-DRBG \
11 - Public key algorithms, like RSA, Elliptic Curves, Diffie-Hellman, \
12 ECDSA and ECDH \
13 - SSL v3 and TLS 1.0, 1.1 and 1.2 \
14 - Abstraction layers for ciphers, hashes, public key operations, \
15 platform abstraction and threading \
16"
17
18HOMEPAGE = "https://tls.mbed.org/"
19
20LICENSE = "Apache-2.0"
Andrew Geissler8fc454f2020-12-11 16:27:59 -060021LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
Andrew Geissler82c905d2020-04-13 13:39:40 -050022
23SECTION = "libs"
24
Andrew Geissler8fc454f2020-12-11 16:27:59 -060025S = "${WORKDIR}/git"
Andrew Geissler69721092021-07-23 12:57:00 -040026SRCREV = "e483a77c85e1f9c1dd2eb1c5a8f552d2617fe400"
Andrew Geissler72956ed2021-01-08 16:11:14 -060027SRC_URI = "git://github.com/ARMmbed/mbedtls.git;protocol=https;branch=development"
Andrew Geissler97771a32021-03-05 15:23:11 -060028SRC_URI += "file://0001-ssl_tls-Increase-size-of-padbuf-to-64.patch"
Andrew Geissler82c905d2020-04-13 13:39:40 -050029
30inherit cmake
31
32PACKAGECONFIG ??= "shared-libs programs"
Andrew Geissler4b7c1152020-11-30 19:55:29 -060033PACKAGECONFIG[shared-libs] = "-DUSE_SHARED_MBEDTLS_LIBRARY=ON,-DUSE_SHARED_MBEDTLS_LIBRARY=OFF"
Andrew Geissler82c905d2020-04-13 13:39:40 -050034PACKAGECONFIG[programs] = "-DENABLE_PROGRAMS=ON,-DENABLE_PROGRAMS=OFF"
Andrew Geissler69721092021-07-23 12:57:00 -040035PACKAGECONFIG[werror] = "-DMBEDTLS_FATAL_WARNINGS=ON,-DMBEDTLS_FATAL_WARNINGS=OFF"
Andrew Geissler82c905d2020-04-13 13:39:40 -050036
37EXTRA_OECMAKE = "-DENABLE_TESTING=OFF -DLIB_INSTALL_DIR:STRING=${libdir}"
38
39PROVIDES += "polarssl"
Patrick Williams213cb262021-08-07 19:21:33 -050040RPROVIDES:${PN} = "polarssl"
Andrew Geissler82c905d2020-04-13 13:39:40 -050041
42PACKAGES =+ "${PN}-programs"
Patrick Williams213cb262021-08-07 19:21:33 -050043FILES:${PN}-programs = "${bindir}/"
Andrew Geissler82c905d2020-04-13 13:39:40 -050044
45BBCLASSEXTEND = "native nativesdk"