blob: c2b3c3d63a1f8ecacf932e1ad3d83f37cb91f87b [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "wolfSSL Lightweight Embedded SSL/TLS Library"
2DESCRIPTION = "wolfSSL, formerly CyaSSL, is a lightweight SSL library written \
3 in C and optimized for embedded and RTOS environments. It can \
4 be up to 20 times smaller than OpenSSL while still supporting \
5 a full TLS client and server, up to TLS 1.3"
6HOMEPAGE = "https://www.wolfssl.com/products/wolfssl"
7BUGTRACKER = "https://github.com/wolfssl/wolfssl/issues"
8SECTION = "libs"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
12PROVIDES += "cyassl"
Patrick Williams213cb262021-08-07 19:21:33 -050013RPROVIDES:${PN} = "cyassl"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014
Andrew Geisslera2681d92020-10-16 10:17:07 -050015SRC_URI = "git://github.com/wolfSSL/wolfssl.git;protocol=https \
Andrew Geisslera2681d92020-10-16 10:17:07 -050016"
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050017SRCREV = "95b91d89133a712a3d0f389442924612c103da24"
Andrew Geissler82c905d2020-04-13 13:39:40 -050018S = "${WORKDIR}/git"
19
20inherit autotools
21
22BBCLASSEXTEND += "native nativesdk"