blob: 3fc574fd0a3c20107ee1fd6c5ebadcaf79b514dd [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Kernel based automounter for linux"
2SECTION = "utils"
3LICENSE = "GPL-2.0"
Andrew Geissler69721092021-07-23 12:57:00 -04004LIC_FILES_CHKSUM = "file://COPYING;md5=ee9324a6f564bb2376b63878ac396798"
Brad Bishop19323692019-04-05 15:28:33 -04005
6DEPENDS += "libtirpc flex-native bison-native e2fsprogs openssl libxml2 util-linux cyrus-sasl libnsl2"
7
8CFLAGS += "-I${STAGING_INCDIR}/tirpc"
9
10inherit autotools-brokensep systemd update-rc.d pkgconfig
11
12SRC_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/autofs-${PV}.tar.gz \
Brad Bishop19323692019-04-05 15:28:33 -040013 file://no-bash.patch \
14 file://cross.patch \
15 file://fix_disable_ldap.patch \
16 file://autofs-5.0.7-fix-lib-deps.patch \
17 file://add-the-needed-stdarg.h.patch \
18 file://using-pkg-config-to-detect-libxml-2.0-and-krb5.patch \
19 file://force-STRIP-to-emtpy.patch \
20 file://remove-bashism.patch \
21 file://fix-the-YACC-rule-to-fix-a-building-failure.patch \
22 file://0001-Define-__SWORD_TYPE-and-_PATH_NSSWITCH_CONF.patch \
23 file://0002-Replace-__S_IEXEC-with-S_IEXEC.patch \
24 file://pkgconfig-libnsl.patch \
25 file://0001-modules-lookup_multi.c-Replace-__S_IEXEC-with-S_IEXE.patch \
26 file://0001-Do-not-hardcode-path-for-pkg.m4.patch \
Brad Bishop868407c2019-11-04 13:24:47 -050027 file://0001-Bug-fix-for-pid_t-not-found-on-musl.patch \
Andrew Geissler69721092021-07-23 12:57:00 -040028 file://0001-Define-__SWORD_TYPE-if-undefined.patch \
Patrick Williams213cb262021-08-07 19:21:33 -050029 file://autofs-5.1.7-use-default-stack-size-for-threads.patch \
Brad Bishop19323692019-04-05 15:28:33 -040030 "
Andrew Geissler69721092021-07-23 12:57:00 -040031SRC_URI[sha256sum] = "a18619e5ad18960fe382354eef33f070e57e4e5711d484b010acde080a003312"
Brad Bishop19323692019-04-05 15:28:33 -040032
33UPSTREAM_CHECK_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/"
34
35INITSCRIPT_NAME = "autofs"
36INITSCRIPT_PARAMS = "defaults"
37
38# FIXME: modules/Makefile has crappy rules that don't obey LDFLAGS
39#CFLAGS += "${LDFLAGS}"
40
41PACKAGECONFIG[systemd] = "--with-systemd=${systemd_unitdir}/system,--without-systemd,systemd"
42
43PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
44
45EXTRA_OEMAKE = "DONTSTRIP=1"
46EXTRA_OECONF += "--disable-mount-locking \
47 --enable-ignore-busy --with-openldap=no \
Brad Bishop2f973922019-11-11 07:58:48 -050048 --with-confdir=${sysconfdir}/default \
49 --with-fifodir=/run \
50 --with-flagdir=/run \
Brad Bishop19323692019-04-05 15:28:33 -040051 --with-sasl=no --with-libtirpc \
Brad Bishop2f973922019-11-11 07:58:48 -050052 --with-mapdir=${sysconfdir} \
Brad Bishop19323692019-04-05 15:28:33 -040053 --with-path=${STAGING_BINDIR_NATIVE} \
54 --with-fifodir=${localstatedir}/run \
55 --with-flagdir=${localstatedir}/run \
56"
57CACHED_CONFIGUREVARS = "ac_cv_path_RANLIB=${RANLIB} \
58 ac_cv_path_RPCGEN=rpcgen \
Brad Bishop2f973922019-11-11 07:58:48 -050059 initdir=${INIT_D_DIR} \
60 piddir=/run \
Brad Bishop19323692019-04-05 15:28:33 -040061"
62
Patrick Williams213cb262021-08-07 19:21:33 -050063do_configure:prepend () {
Brad Bishop19323692019-04-05 15:28:33 -040064 if [ ! -e ${S}/acinclude.m4 ]; then
65 cp ${S}/aclocal.m4 ${S}/acinclude.m4
66 fi
67 cp ${STAGING_DATADIR_NATIVE}/aclocal/pkg.m4 .
68}
69
Patrick Williams213cb262021-08-07 19:21:33 -050070do_install:append () {
Brad Bishop19323692019-04-05 15:28:33 -040071 # samples have been removed from SUBDIRS from 5.1.5, need to install separately
72 oe_runmake 'DESTDIR=${D}' install_samples
73
74 if [ -d ${D}/run ]; then
75 rmdir ${D}/run
76 fi
77 if [ -d ${D}${localstatedir}/run ]; then
78 rmdir ${D}${localstatedir}/run
79 fi
Brad Bishop2f973922019-11-11 07:58:48 -050080 # On hybrid systemd/sysvinit builds, we need to install the sysvinit script by hand.
81 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
82 install -d -m 755 ${D}${INIT_D_DIR}
83 install -m 755 ${S}/samples/rc.autofs ${D}${INIT_D_DIR}/autofs
84 fi
Brad Bishop19323692019-04-05 15:28:33 -040085}
86SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}"
87
Andrew Geissler69721092021-07-23 12:57:00 -040088# all the libraries are unversioned, so don't pack it on PN-dev
89SOLIBS = ".so"
90FILES_SOLIBSDEV = ""
91# Some symlinks are created in plugins dir e.g.
92# mount_nfs4.so -> mount_nfs.so
Patrick Williams213cb262021-08-07 19:21:33 -050093INSANE_SKIP:${PN} = "dev-so"
Brad Bishop19323692019-04-05 15:28:33 -040094
Patrick Williams213cb262021-08-07 19:21:33 -050095RPROVIDES:${PN} += "${PN}-systemd"
96RREPLACES:${PN} += "${PN}-systemd"
97RCONFLICTS:${PN} += "${PN}-systemd"
98SYSTEMD_SERVICE:${PN} = "autofs.service"