blob: cc2320788894a97856e5a9d83aae31cf7f967d5d [file] [log] [blame]
Andrew Geissler4b7c1152020-11-30 19:55:29 -06001SUMMARY = "Web-based Traffic and Security Network Traffic Monitoring"
2DESCRIPTION = "ntopng is a web-based network traffic monitoring application \
3released under GPLv3. It is the new incarnation of the original \
4ntop written in 1998, and now revamped in terms of performance, \
5usability, and features."
6
7SECTION = "console/network"
8
9DEPENDS = "curl libmaxminddb libpcap lua mariadb ndpi json-c rrdtool zeromq"
Patrick Williams213cb262021-08-07 19:21:33 -050010RDEPENDS:${PN} = "bash redis"
Andrew Geissler4b7c1152020-11-30 19:55:29 -060011LICENSE = "GPLv3"
12LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
13
14SRCREV = "5e649a2d1130b4a3ab0c5bb673d615172cc0bdbb"
15SRC_URI = "git://github.com/ntop/ntopng.git;protocol=git;branch=4.2-stable \
16 file://0001-configure.seed-fix-configure-error.patch \
17 file://0001-configure.seed-fix-host-contamination.patch \
18 file://0001-Makefile.in-don-t-use-the-internal-lua.patch \
19 file://0001-autogen.sh-generate-configure.ac-only.patch \
20 file://0001-configure.seed-not-check-clang-on-host.patch \
21 file://ntopng.service \
22"
23
24S = "${WORKDIR}/git"
25
26# don't use the lua under thirdparty as it supports cross compiling badly
27export LUA_LIB = "${STAGING_LIBDIR}/liblua.a"
28
Patrick Williams213cb262021-08-07 19:21:33 -050029LDFLAGS:append:mipsarch = " -latomic"
30LDFLAGS:append:powerpc = " -latomic"
31LDFLAGS:append:riscv32 = " -latomic"
Andrew Geissler4b7c1152020-11-30 19:55:29 -060032inherit autotools-brokensep gettext systemd
33
Patrick Williams213cb262021-08-07 19:21:33 -050034do_install:append() {
Andrew Geissler4b7c1152020-11-30 19:55:29 -060035 install -d ${D}${systemd_unitdir}/system/
36 install -m 0644 ${WORKDIR}/ntopng.service ${D}${systemd_unitdir}/system
37}
38
Patrick Williams213cb262021-08-07 19:21:33 -050039FILES:${PN} += "\
Andrew Geissler4b7c1152020-11-30 19:55:29 -060040 ${systemd_unitdir}/system/ntopng.service"
41
Patrick Williams213cb262021-08-07 19:21:33 -050042FILES:${PN}-doc += "\
Andrew Geissler4b7c1152020-11-30 19:55:29 -060043 /usr/man/man8/ntopng.8"
44
Patrick Williams213cb262021-08-07 19:21:33 -050045do_configure:prepend() {
Andrew Geissler4b7c1152020-11-30 19:55:29 -060046 ${S}/autogen.sh
47}
48
Patrick Williams213cb262021-08-07 19:21:33 -050049SYSTEMD_SERVICE:${PN} = "ntopng.service"