blob: f20013b192c2779a8cf8401b6c5de98f33053bb7 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Lightweight http(s) proxy daemon"
2HOMEPAGE = "https://tinyproxy.github.io/"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
5
6SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BP}.tar.gz \
Brad Bishope42b3e32020-01-15 22:08:42 -05007 file://disable-documentation.patch \
8 file://tinyproxy.service \
9 file://tinyproxy.conf \
10 "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050012SRC_URI[md5sum] = "658db5558ffb849414341b756a546a99"
13SRC_URI[sha256sum] = "20f74769e40144e4d251d2977cc4c40d2d428a2bec8c1b8709cd07315454baef"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014
Andrew Geissler89770b02020-06-13 10:40:47 -050015UPSTREAM_CHECK_URI = "https://github.com/tinyproxy/tinyproxy/releases"
16
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017EXTRA_OECONF += " \
18 --enable-filter \
19 --enable-transparent \
20 --enable-reverse \
21 --enable-upstream \
22 --enable-xtinyproxy \
23 "
24
25inherit autotools systemd useradd
26
27#User specific
28USERADD_PACKAGES = "${PN}"
Patrick Williams213cb262021-08-07 19:21:33 -050029USERADD_PARAM:${PN} = "--system --home /dev/null \
Brad Bishope42b3e32020-01-15 22:08:42 -050030 --no-user-group --gid nogroup tinyproxy"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031
32SYSTEMD_PACKAGES += "${BPN}"
Patrick Williams213cb262021-08-07 19:21:33 -050033SYSTEMD_SERVICE:${PN} = "tinyproxy.service"
34SYSTEMD_AUTO_ENABLE:${PN} = "enable"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080035
Patrick Williams213cb262021-08-07 19:21:33 -050036do_install:append() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080037 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
38 install -d ${D}${systemd_system_unitdir}
39 install -m 0644 ${WORKDIR}/tinyproxy.service ${D}${systemd_system_unitdir}
40 fi
Brad Bishope42b3e32020-01-15 22:08:42 -050041 install -m 0644 ${WORKDIR}/tinyproxy.conf ${D}${sysconfdir}/tinyproxy.conf
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080042}