blob: 8ab8b7b84fa2096417add13aed43adff65d65cd6 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "Unbound is a validating, recursive, and caching DNS resolver"
2DESCRIPTION = "Unbound's design is a set of modular components which incorporate \
3 features including enhanced security (DNSSEC) validation, Internet Protocol \
4 Version 6 (IPv6), and a client resolver library API as an integral part of the \
5 architecture"
6
7HOMEPAGE = "https://www.unbound.net/"
8SECTION = "net"
9LICENSE = "BSD-3-Clause"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=5308494bc0590c0cb036afd781d78f06"
11
12SRC_URI = "git://github.com/NLnetLabs/unbound.git;protocol=http;branch=master \
Andrew Geissler4b7c1152020-11-30 19:55:29 -060013 file://0001-contrib-add-yocto-compatible-init-script.patch \
Brad Bishop26bdd442019-08-16 17:08:17 -040014"
Andrew Geissler4b7c1152020-11-30 19:55:29 -060015SRCREV="52b04806f4236c37acd10179ab465a54adc7e86a"
Brad Bishop26bdd442019-08-16 17:08:17 -040016
17inherit autotools pkgconfig systemd update-rc.d
18
19DEPENDS = "openssl libevent libtool-native bison-native expat"
Patrick Williams213cb262021-08-07 19:21:33 -050020RDEPENDS:${PN} = "bash openssl-bin daemonize"
Brad Bishop26bdd442019-08-16 17:08:17 -040021
22S = "${WORKDIR}/git"
23
24EXTRA_OECONF = "--with-libexpat=${STAGING_EXECPREFIXDIR} \
25 --with-ssl=${STAGING_EXECPREFIXDIR} \
Andrew Geissler82c905d2020-04-13 13:39:40 -050026 libtool=${HOST_SYS}-libtool \
Brad Bishop26bdd442019-08-16 17:08:17 -040027"
28
29
30PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'largefile systemd', d)}"
31PACKAGECONFIG[dnscrypt] = "--enable-dnscrypt, --disable-dnscrypt, libsodium"
32PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
33PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"
34
Patrick Williams213cb262021-08-07 19:21:33 -050035do_install:append() {
Brad Bishop26bdd442019-08-16 17:08:17 -040036 install -d ${D}${systemd_unitdir}/system
37 install -m 0644 ${B}/contrib/unbound.service ${D}${systemd_unitdir}/system
38
39 install -d ${D}${sysconfdir}/init.d
40 install -m 0755 ${S}/contrib/unbound.init ${D}${sysconfdir}/init.d/unbound
41}
42
Patrick Williams213cb262021-08-07 19:21:33 -050043SYSTEMD_SERVICE:${PN} = "${BPN}.service"
Brad Bishop26bdd442019-08-16 17:08:17 -040044
45INITSCRIPT_NAME = "unbound"
46INITSCRIPT_PARAMS = "defaults"