blob: 6ccefd22e521ad1263d199dbcab43da285915fab [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001DESCRIPTION="Protocol Buffers with small code size"
2LICENSE="Zlib"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=9db4b73a55a3994384112efcdb37c01f"
4
5DEPENDS = "protobuf-native"
6
7SRC_URI = "git://github.com/nanopb/nanopb.git"
Andrew Geissler32b11992021-03-31 13:37:05 -05008SRCREV = "c9124132a604047d0ef97a09c0e99cd9bed2c818"
Brad Bishope42b3e32020-01-15 22:08:42 -05009
10S = "${WORKDIR}/git"
11
Andrew Geissler82c905d2020-04-13 13:39:40 -050012inherit cmake python3native
Brad Bishope42b3e32020-01-15 22:08:42 -050013
Patrick Williams213cb262021-08-07 19:21:33 -050014do_install:append() {
Brad Bishope42b3e32020-01-15 22:08:42 -050015 install -Dm 0755 ${S}/generator/nanopb_generator.py ${D}${bindir}/nanopb_generator.py
16 install -Dm 0755 ${S}/generator/protoc-gen-nanopb ${D}${bindir}/protoc-gen-nanopb
17 install -Dm 0755 ${S}/generator/proto/__init__.py ${D}${PYTHON_SITEPACKAGES_DIR}/proto/__init__.py
18}
19
Patrick Williams213cb262021-08-07 19:21:33 -050020FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}"
21FILES:${PN}-dev += "${libdir}/cmake/${BPN}"
Brad Bishope42b3e32020-01-15 22:08:42 -050022
Patrick Williams213cb262021-08-07 19:21:33 -050023RDEPENDS:${PN} += "\
Brad Bishope42b3e32020-01-15 22:08:42 -050024 ${PYTHON_PN}-protobuf \
25 protobuf-compiler \
26"
27
28BBCLASSEXTEND = "native nativesdk"
Andrew Geissler82c905d2020-04-13 13:39:40 -050029