blob: 46b6788a8f8c3c54e2e63c7289554ac0f93343e2 [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001SUMMARY = "System performance benchmark"
2HOMEPAGE = "http://github.com/akopytov/sysbench"
3SECTION = "console/tests"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
6
7inherit autotools
8
9# The project has moved from Sourceforge to Launchpad, to Github. Use the source tarball from
10# Launchpad until the next release is available from Github.
Andrew Geissler69721092021-07-23 12:57:00 -040011SRC_URI = "https://launchpad.net/ubuntu/+archive/primary/+files/${BPN}_${PV}.orig.tar.gz \
12 file://0001-Adding-volatile-modifier-to-tmp-variable-in-memory-t.patch \
13 "
Patrick Williamsddad1a12017-02-23 20:36:32 -060014
15SRC_URI[md5sum] = "3a6d54fdd3fe002328e4458206392b9d"
16SRC_URI[sha256sum] = "83fa7464193e012c91254e595a89894d8e35b4a38324b52a5974777e3823ea9e"
17
Brad Bishop6e60e8b2018-02-01 10:27:11 -050018PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)}"
Patrick Williamsddad1a12017-02-23 20:36:32 -060019PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
20PACKAGECONFIG[aio] = "--enable-aio,--disable-aio,libaio,"
21PACKAGECONFIG[mysql] = "--with-mysql \
22 --with-mysql-includes=${STAGING_INCDIR}/mysql \
23 --with-mysql-libs=${STAGING_LIBDIR}, \
24 --without-mysql,mysql5"
25
Patrick Williams213cb262021-08-07 19:21:33 -050026do_configure:prepend() {
Patrick Williamsddad1a12017-02-23 20:36:32 -060027 touch ${S}/NEWS ${S}/AUTHORS
28}