blob: 66da1826fc0bcc03a9d645e277fc046c80bd142f [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Intel(R) Enclosure LED Utilities"
2
3DESCRIPTION = "The utilities are designed primarily to be used on storage servers \
4 utilizing MD devices (aka Linux Software RAID) for RAID arrays.\
5"
6HOMEPAGE = "https://github.com/intel/ledmon"
7
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
10"
11
12DEPENDS = "sg3-utils udev"
13
Brad Bishop868407c2019-11-04 13:24:47 -050014inherit autotools systemd
Brad Bishopc342db32019-05-15 21:57:59 -040015
Patrick Williams213cb262021-08-07 19:21:33 -050016SYSTEMD_SERVICE:${PN} = "ledmon.service"
Brad Bishopc342db32019-05-15 21:57:59 -040017
Brad Bishop868407c2019-11-04 13:24:47 -050018# 0.93
Brad Bishopc342db32019-05-15 21:57:59 -040019SRC_URI = "git://github.com/intel/ledmon;branch=master \
20 file://0002-include-sys-select.h-and-sys-types.h.patch \
Brad Bishop868407c2019-11-04 13:24:47 -050021 file://0001-Don-t-build-with-Werror-to-fix-compile-error.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040022 "
23
Brad Bishop868407c2019-11-04 13:24:47 -050024SRCREV = "1d72f9cb5c9163b2ecdf19709935720e65f5b90e"
Brad Bishopc342db32019-05-15 21:57:59 -040025
26COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
Patrick Williams213cb262021-08-07 19:21:33 -050027COMPATIBLE_HOST:libc-musl = "null"
Brad Bishopc342db32019-05-15 21:57:59 -040028
29S = "${WORKDIR}/git"
30EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}' CFLAGS='${CFLAGS}'"
31
Brad Bishop868407c2019-11-04 13:24:47 -050032# The ledmon sources include headers in ${S}/config to build but not in CFLAGS.
33# We need to add this include path in CFLAGS.
34CFLAGS += "-I${S}/config"
35
Patrick Williams213cb262021-08-07 19:21:33 -050036do_install:append() {
Brad Bishop868407c2019-11-04 13:24:47 -050037 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
38 install -d ${D}${systemd_unitdir}/system
39 install -m 0755 ${S}/systemd/ledmon.service ${D}${systemd_unitdir}/system
40 fi
Brad Bishopc342db32019-05-15 21:57:59 -040041}