blob: e86b9dcf992f3e40c7b5e042b125e28937fdb109 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Linux Kernel Crypto API User Space Interface Library"
2HOMEPAGE = "http://www.chronox.de/libkcapi.html"
3LICENSE = "BSD | GPL-2.0"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05004LIC_FILES_CHKSUM = "file://COPYING;md5=c78be93ed8d1637f2a3f4a83ff9d5f54"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08005
6DEPENDS = "libtool"
7
8S = "${WORKDIR}/git"
Andrew Geissler4b7c1152020-11-30 19:55:29 -06009SRCREV = "d41284525ec8960e9a828979cfe269012b7df8db"
10SRC_URI = "git://github.com/smuellerDD/libkcapi.git \
11 file://0001-Disable-use-of-__NR_io_getevents-when-not-defined.patch \
12 "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013
14inherit autotools
15
16PACKAGECONFIG ??= ""
Brad Bishop19323692019-04-05 15:28:33 -040017PACKAGECONFIG[testapp] = "--enable-kcapi-test,,,bash"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018PACKAGECONFIG[apps] = "--enable-kcapi-speed --enable-kcapi-hasher --enable-kcapi-rngapp --enable-kcapi-encapp --enable-kcapi-dgstapp,,,"
19
Patrick Williams213cb262021-08-07 19:21:33 -050020do_install:append() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021 # bindir contains testapp and apps. However it is always created, even
22 # when no binaries are installed (empty bin_PROGRAMS in Makefile.am),
23 rmdir --ignore-fail-on-non-empty ${D}${bindir}
Brad Bishop19323692019-04-05 15:28:33 -040024
25 # Remove the generated binary checksum files
26 rm -f ${D}${bindir}/.*.hmac
27 rm -f ${D}${libdir}/.*.hmac
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028}
29
Patrick Williams213cb262021-08-07 19:21:33 -050030CPPFLAGS:append:libc-musl:toolchain-clang = " -Wno-error=sign-compare"