blob: 3a018bb519cc69fb14f310788c46fcbf83789fe3 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "GTK+2 standard themes"
2HOMEPAGE = "http://ftp.gnome.org/pub/GNOME/sources/gnome-themes-standard/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4SECTION = "x11/gnome"
5
6LICENSE = "LGPL-2.1"
Brad Bishop90ca7472019-08-20 09:15:15 -04007LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1"
Brad Bishop26bdd442019-08-16 17:08:17 -04008
Brad Bishop8410d612019-11-25 09:40:59 -05009inherit gnomebase gettext gtk-icon-cache upstream-version-is-even features_check
Brad Bishop26bdd442019-08-16 17:08:17 -040010
11ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
12
13DEPENDS += "intltool-native gtk+"
14
Brad Bishop90ca7472019-08-20 09:15:15 -040015SRC_URI[archive.md5sum] = "f9f2c6c521948da427f702372e16f826"
16SRC_URI[archive.sha256sum] = "7c4ba0bff001f06d8983cfc105adaac42df1d1267a2591798a780bac557a5819"
Brad Bishop26bdd442019-08-16 17:08:17 -040017
18EXTRA_OECONF = "--disable-gtk3-engine"
19
Patrick Williams213cb262021-08-07 19:21:33 -050020do_install:append() {
Brad Bishop26bdd442019-08-16 17:08:17 -040021 # Only building Adwaita, remove highcontrast files
22 rm -rf ${D}${prefix}/share/themes/HighContrast \
23 ${D}${prefix}/share/icons
24
25 # The libtool archive file is unneeded with shared libs on modern Linux
26 rm -rf ${D}${libdir}/gtk-2.0/2.10.0/engines/libadwaita.la
27}
28
29# There could be gnome-theme-highcontrast as well but that requires
30# gtk+3 and includes lots of icons (is also broken with B != S).
31PACKAGES += "gnome-theme-adwaita \
32 gnome-theme-adwaita-dark \
33 "
34
Patrick Williams213cb262021-08-07 19:21:33 -050035FILES:gnome-theme-adwaita = "${prefix}/share/themes/Adwaita \
Brad Bishop26bdd442019-08-16 17:08:17 -040036 ${libdir}/gtk-2.0/2.10.0/engines/libadwaita.so"
37
Patrick Williams213cb262021-08-07 19:21:33 -050038FILES:gnome-theme-adwaita-dark = "${prefix}/share/themes/Adwaita-dark"
39RDEPENDS:gnome-theme-adwaita-dark = "gnome-theme-adwaita"
Brad Bishop26bdd442019-08-16 17:08:17 -040040
41# gnome-themes-standard is empty and doesn't exist
Patrick Williams213cb262021-08-07 19:21:33 -050042RDEPENDS:${PN}-dev = ""