blob: 99953189e669a3bcc8f0ba914132b6d227616b8b [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Framebuffer image and doc viewer tools"
2DESCRIPTION = "The fbida project contains a few applications for viewing and editing images, \
3 with the main focus being photos."
4HOMEPAGE = "http://linux.bytesex.org/fbida/"
5AUTHOR = "Gerd Hoffmann"
6SECTION = "utils"
7
8LICENSE = "GPLv2"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05009LIC_FILES_CHKSUM = "file://COPYING;md5=e8feb78a32950a909621bbb51f634b39"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050010
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050011DEPENDS = "virtual/libiconv jpeg fontconfig freetype libexif libdrm pixman poppler libepoxy cairo"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050012
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013SRC_URI = "https://www.kraxel.org/releases/fbida/fbida-${PV}.tar.gz \
14 file://0001-Avoid-using-host-path.patch \
15 file://fix-preprocessor.patch \
16 file://support-jpeg-turbo.patch \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050017 file://cairo-weak-detect.patch \
18 file://fbida-gcc10.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050019 "
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050020SRC_URI[sha256sum] = "95b7c01556cb6ef9819f358b314ddfeb8a4cbe862b521a3ed62f03d163154438"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050021
Andrew Geisslerd688a012020-09-18 13:36:00 -050022inherit pkgconfig features_check
23
24# Depends on libepoxy
25REQUIRED_DISTRO_FEATURES = "opengl"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050026
Patrick Williamsb48b7b42016-08-17 15:04:38 -050027EXTRA_OEMAKE = "STRIP= 'srcdir=${S}' -f ${S}/GNUmakefile"
28
29PACKAGECONFIG ??= "gif png curl"
30PACKAGECONFIG[curl] = ",,curl"
31PACKAGECONFIG[gif] = ",,giflib"
32PACKAGECONFIG[png] = ",,libpng"
33PACKAGECONFIG[tiff] = ",,tiff"
34PACKAGECONFIG[motif] = ",,libx11 libxext libxpm libxt openmotif"
35PACKAGECONFIG[webp] = ",,libwebp"
36PACKAGECONFIG[lirc] = ",,lirc"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050037# This can only be enabled when cairo has egl enabled in its packageconfig support too
38PACKAGECONFIG[egl] = ",,"
39
40EXTRA_OEMAKE += ""${@bb.utils.contains('PACKAGECONFIG', 'egl', 'HAVE_CAIRO_GL=yes', 'HAVE_CAIRO_GL=no', d)}""
Patrick Williamsb48b7b42016-08-17 15:04:38 -050041
42do_compile() {
43 sed -i -e 's# fbgs# \$(srcdir)/fbgs#; s#-Ijpeg#-I\$(srcdir)/jpeg#; s# jpeg/# \$(srcdir)/jpeg/#' ${S}/GNUmakefile
44 sed -i -e 's:/sbin/ldconfig:echo x:' ${S}/mk/Autoconf.mk
Brad Bishop6e60e8b2018-02-01 10:27:11 -050045 sed -i -e 's: cpp: ${CPP}:' ${S}/GNUmakefile
Patrick Williamsb48b7b42016-08-17 15:04:38 -050046
47 # Be sure to respect preferences (force to "no")
48 # Also avoid issues when ${BUILD_ARCH} == ${HOST_ARCH}
Brad Bishop6e60e8b2018-02-01 10:27:11 -050049 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'curl', d)}" ]; then
Patrick Williamsb48b7b42016-08-17 15:04:38 -050050 sed -i -e '/^HAVE_LIBCURL/s/:=.*$/:= no/' ${S}/GNUmakefile
51 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -050052 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'gif', d)}" ]; then
Patrick Williamsb48b7b42016-08-17 15:04:38 -050053 sed -i -e '/^HAVE_LIBGIF/s/:=.*$/:= no/' ${S}/GNUmakefile
54 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -050055 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'png', d)}" ]; then
Patrick Williamsb48b7b42016-08-17 15:04:38 -050056 sed -i -e '/^HAVE_LIBPNG/s/:=.*$/:= no/' ${S}/GNUmakefile
57 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -050058 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'tiff', d)}" ]; then
Patrick Williamsb48b7b42016-08-17 15:04:38 -050059 sed -i -e '/^HAVE_LIBTIFF/s/:=.*$/:= no/' ${S}/GNUmakefile
60 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -050061 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'motif', d)}" ]; then
Patrick Williamsb48b7b42016-08-17 15:04:38 -050062 sed -i -e '/^HAVE_MOTIF/s/:=.*$/:= no/' ${S}/GNUmakefile
63 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -050064 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'webp', d)}" ]; then
Patrick Williamsb48b7b42016-08-17 15:04:38 -050065 sed -i -e '/^HAVE_LIBWEBP/s/:=.*$/:= no/' ${S}/GNUmakefile
66 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -050067 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'lirc', d)}" ]; then
Patrick Williamsb48b7b42016-08-17 15:04:38 -050068 sed -i -e '/^HAVE_LIBLIRC/s/:=.*$/:= no/' ${S}/GNUmakefile
69 fi
70
71 oe_runmake
72}
73
74do_install() {
75 oe_runmake 'DESTDIR=${D}' install
76}
77
Patrick Williams213cb262021-08-07 19:21:33 -050078RDEPENDS:${PN} = "ttf-dejavu-sans-mono bash"