blob: 06a02bb1c3b6e77cd46558baa3b16f157d94912f [file] [log] [blame]
Brad Bishop15ae2502019-06-18 21:44:24 -04001SUMMARY = "Timing analysis tools for suspend/resume/boot"
2DESCRIPTION = "This tool suite is designed to assist kernel and OS developers \
3in optimizing their linux stack's suspend/resume & boot time."
4HOMEPAGE = "https://01.org/pm-graph"
5LICENSE = "GPL-2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
7
Brad Bishopa891d152019-09-13 06:17:45 -04008SRCREV = "cf59527dc24fdd2f314ae4dcaeb3d68a117988f6"
Brad Bishopc8f47122019-06-24 09:36:18 -04009SRC_URI = "git://github.com/intel/pm-graph.git \
Brad Bishop26bdd442019-08-16 17:08:17 -040010 file://0001-Makefile-fix-multilib-build-failure.patch \
Brad Bishopa891d152019-09-13 06:17:45 -040011 file://0001-sleepgraph.py-use-python3.patch \
Andrew Geisslerc87764f2020-06-27 00:16:32 -050012 file://0001-sleepgraph-add-support-for-RT-kernel-ftrace-flags.patch \
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070013 file://0001-sleepgraph.py-parse-unfished-cpu-exec-line.patch \
Brad Bishop26bdd442019-08-16 17:08:17 -040014"
Brad Bishop15ae2502019-06-18 21:44:24 -040015S = "${WORKDIR}/git"
16
Andrew Geissler82c905d2020-04-13 13:39:40 -050017# Apart from the listed RDEPENDS, analyze-suspend depends on some features
18# provided by the kernel. These options are:
19# - CONFIG_PM_DEBUG=y
20# - CONFIG_PM_SLEEP_DEBUG=y
21# - CONFIG_FTRACE=y
22# - CONFIG_FUNCTION_TRACER=y
23# - CONFIG_FUNCTION_GRAPH_TRACER=y
24
Brad Bishop15ae2502019-06-18 21:44:24 -040025COMPATIBLE_HOST='(i.86|x86_64).*'
Brad Bishopc8f47122019-06-24 09:36:18 -040026EXTRA_OEMAKE = "PREFIX=${prefix} DESTDIR=${D} BASELIB=${baselib}"
Brad Bishop15ae2502019-06-18 21:44:24 -040027
28do_install() {
29 oe_runmake install
Andrew Geissler82c905d2020-04-13 13:39:40 -050030 install -Dm 0755 ${S}/analyze_suspend.py ${D}${bindir}/analyze_suspend.py
Brad Bishop15ae2502019-06-18 21:44:24 -040031}
32
Patrick Williams213cb262021-08-07 19:21:33 -050033RDEPENDS:${PN} += "python3-core python3-threading python3-datetime python3-compression"
34RPROVIDES:${PN} = "analyze-suspend"
Andrew Geissler82c905d2020-04-13 13:39:40 -050035BBCLASSEXTEND = "native nativesdk"