blob: b478b86baea2f0a1ba644bd1b590c315da275bfd [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "A garbage collector for C and C++"
2
3DESCRIPTION = "The Boehm-Demers-Weiser conservative garbage collector can be\
4 used as a garbage collecting replacement for C malloc or C++ new. It allows\
5 you to allocate memory basically as you normally would, without explicitly\
6 deallocating memory that is no longer useful. The collector automatically\
7 recycles memory when it determines that it can no longer be otherwise\
8 accessed.\
9 The collector is also used by a number of programming language\
10 implementations that either use C as intermediate code, want to facilitate\
11 easier interoperation with C libraries, or just prefer the simple collector\
12 interface.\
13 Alternatively, the garbage collector may be used as a leak detector for C\
14 or C++ programs, though that is not its primary goal.\
15 Empirically, this collector works with most unmodified C programs, simply\
16 by replacing malloc with GC_malloc calls, replacing realloc with GC_realloc\
17 calls, and removing free calls."
18
19HOMEPAGE = "http://www.hboehm.info/gc/"
20SECTION = "devel"
21LICENSE = "MIT"
22LIC_FILES_CHKSUM = "file://README.QUICK;md5=81b447d779e278628c843aef92f088fa"
23
Brad Bishope42b3e32020-01-15 22:08:42 -050024DEPENDS = "libatomic-ops"
Brad Bishopc342db32019-05-15 21:57:59 -040025
Brad Bishope42b3e32020-01-15 22:08:42 -050026SRCREV = "d3dede3ce4462cd82a15f161af797ca51654546a"
27SRC_URI = "git://github.com/ivmai/bdwgc.git;branch=release-8_0"
Brad Bishopc342db32019-05-15 21:57:59 -040028
29S = "${WORKDIR}/git"
30
Brad Bishopc342db32019-05-15 21:57:59 -040031inherit autotools pkgconfig
32
Brad Bishop00ab2372019-10-14 11:06:18 -040033EXTRA_OECONF += "--enable-cpluscplus"
34
Patrick Williams213cb262021-08-07 19:21:33 -050035CFLAGS:append:libc-musl = " -D_GNU_SOURCE -DNO_GETCONTEXT -DSEARCH_FOR_DATA_START -DUSE_MMAP -DHAVE_DL_ITERATE_PHDR"
Brad Bishop00ab2372019-10-14 11:06:18 -040036
Patrick Williams213cb262021-08-07 19:21:33 -050037FILES:${PN}-doc = "${datadir}"
Brad Bishope42b3e32020-01-15 22:08:42 -050038
Brad Bishopc342db32019-05-15 21:57:59 -040039BBCLASSEXTEND = "native nativesdk"