blob: ed73408cdb3fd908f130b0520aac5aa9c64e6e4a [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "DJB daemontools"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05002HOMEPAGE = "http://cr.yp.to/daemontools.html"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05003DESCRIPTION = "supervise monitors a service. It starts the service and restarts the \
4service if it dies. The companion svc program stops, pauses, or restarts \
5the service on sysadmin request. The svstat program prints a one-line \
6status report. \
7multilog saves error messages to one or more logs. It optionally timestamps \
8each line and, for each log, includes or excludes lines matching specified \
9patterns. It automatically rotates logs to limit the amount of disk space \
10used. If the disk fills up, it pauses and tries again, without losing any \
11data."
12
13SECTION = "System/Servers"
14
Brad Bishop0f291cc2019-09-01 15:16:57 -040015LIC_FILES_CHKSUM = "file://src/prot.c;beginline=1;endline=1;md5=96964cadf07e8f8c1e2ffb3b507dd647"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050016LICENSE = "PD"
17
18SRC_URI = "http://cr.yp.to/daemontools/${BPN}-${PV}.tar.gz \
Andrew Geissler82c905d2020-04-13 13:39:40 -050019 file://0001-error.h-include-errno.h-instead-of-extern-int.diff \
20 file://0002-supervise.c-.-supervise-may-be-a-symlink-if-it-s-da.diff \
21 file://cross-compile.patch \
22 file://0001-daemontools-Fix-QA-Issue.patch \
23"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050024
25SRC_URI[md5sum] = "1871af2453d6e464034968a0fbcb2bfc"
26SRC_URI[sha256sum] = "a55535012b2be7a52dcd9eccabb9a198b13be50d0384143bd3b32b8710df4c1f"
27
Andrew Geissler82c905d2020-04-13 13:39:40 -050028S = "${WORKDIR}/admin/${BP}"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050029
30do_compile() {
31 ./package/compile
32}
33
34do_install() {
35 install -d ${D}/${bindir}
36}
37
Patrick Williams213cb262021-08-07 19:21:33 -050038do_install:append:class-target() {
Patrick Williamsb48b7b42016-08-17 15:04:38 -050039 install -m755 ${S}/command/* ${D}/${bindir}
40}
41
Andrew Geissler82c905d2020-04-13 13:39:40 -050042inherit update-alternatives
43ALTERNATIVE_PRIORITY = "100"
Patrick Williams213cb262021-08-07 19:21:33 -050044ALTERNATIVE:${PN} = "svc svok"