blob: 034c2871a911174da9f0d64a5aff9cc8317655c7 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Default display timings and resolutions for fbset"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05002HOMEPAGE = "http://users.telenet.be/geertu/Linux/fbdev/"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05003LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5
6PV = "0.1.0"
7PR = "r6"
8
9SRC_URI = "file://fb.modes"
10S = "${WORKDIR}"
11
12do_install() {
13 install -d ${D}${sysconfdir}
14 install -m 0644 ${WORKDIR}/fb.modes ${D}${sysconfdir}
15}
16
Patrick Williamsb48b7b42016-08-17 15:04:38 -050017# fb.modes file is MACHINE_ARCH, base.bbclass correctly changes it to MACHINE_ARCH, but too late for allarch.bbclass
18# to disable "all" behavior (found when comparing qemuarm and qemux86 signatures)
19PACKAGE_ARCH = "${MACHINE_ARCH}"
20
Patrick Williams213cb262021-08-07 19:21:33 -050021CONFFILES:${PN} = "${sysconfdir}/fb.modes"