blob: 8d3992a6eca3e17b94fe392367ba1389c4d554de [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001require ${BPN}.inc
2
3DEPENDS = "zlib-native jpeg-native libpng-native libxext-native libxft-native"
4
5inherit native
6
7EXTRA_OECMAKE += " \
8 -DOPTION_BUILD_SHARED_LIBS=OFF \
9 -DOPTION_USE_THREADS=OFF \
10 -DOPTION_USE_XDBE=OFF \
11 -DOPTION_USE_XFT=OFF \
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070012 -DFLTK_BUILD_TEST=OFF \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013 -DOPTION_USE_XINERAMA=OFF \
14 -DOPTION_USE_XFIXES=OFF \
15 -DOPTION_USE_XCURSOR=OFF \
16"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070018# lib/libfltk.a(Fl_Native_File_Chooser.cxx.o): undefined reference to symbol 'dlsym@@GLIBC_2.2.5'
19LDFLAGS += "-ldl"
20
Patrick Williams213cb262021-08-07 19:21:33 -050021do_install:append() {
Brad Bishopd7bf8c12018-02-25 22:55:05 -050022 # make sure native fltk-config is not used accidentaly
23 rm -f ${D}${bindir}/fltk-config
24}