blob: 557af0e858ea7eaeebb77f0cbf667c68c7ecd4b0 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Fast, multi-threaded malloc() and nifty performance analysis tools"
2HOMEPAGE = "https://github.com/gperftools/gperftools"
Andrew Geissler32b11992021-03-31 13:37:05 -05003DESCRIPTION = "The gperftools, previously called google-perftools, package contains some \
4utilities to improve and analyze the performance of C++ programs. \
5Included are an optimized thread-caching malloc() and cpu and heap profiling utilities. \
6"
7
Andrew Geissler82c905d2020-04-13 13:39:40 -05008LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://COPYING;md5=762732742c73dc6c7fbe8632f06c059a"
10
Patrick Williams213cb262021-08-07 19:21:33 -050011DEPENDS:append:libc-musl = " libucontext"
Andrew Geissler32b11992021-03-31 13:37:05 -050012
13SRCREV = "f7c6fb6c8e99d6b1b725e5994373bcd19ffdf8fd"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014SRC_URI = "git://github.com/gperftools/gperftools \
15 file://0001-Support-Atomic-ops-on-clang.patch \
16 file://0001-fix-build-with-musl-libc.patch \
17 file://0001-disbale-heap-checkers-and-debug-allocator-on-musl.patch \
18 file://disable_libunwind_aarch64.patch \
19 file://sgidef.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050020 "
21
Patrick Williams213cb262021-08-07 19:21:33 -050022SRC_URI:append:libc-musl = " file://ppc-musl.patch"
Andrew Geissler32b11992021-03-31 13:37:05 -050023
Andrew Geissler82c905d2020-04-13 13:39:40 -050024inherit autotools
25
26S = "${WORKDIR}/git"
27
28# On mips, we have the following error.
29# do_page_fault(): sending SIGSEGV to ls for invalid read access from 00000008
30# Segmentation fault (core dumped)
Patrick Williams213cb262021-08-07 19:21:33 -050031COMPATIBLE_HOST:mipsarch = "null"
32COMPATIBLE_HOST:riscv64 = "null"
33COMPATIBLE_HOST:riscv32 = "null"
Andrew Geissler82c905d2020-04-13 13:39:40 -050034
35# Disable thumb1
36# {standard input}: Assembler messages:
37# {standard input}:434: Error: lo register required -- `ldr pc,[sp]'
38# Makefile:4538: recipe for target 'src/base/libtcmalloc_la-linuxthreads.lo' failed
Patrick Williams213cb262021-08-07 19:21:33 -050039ARM_INSTRUCTION_SET:armv5 = "arm"
40ARM_INSTRUCTION_SET:toolchain-clang:arm = "arm"
Andrew Geissler82c905d2020-04-13 13:39:40 -050041
Patrick Williams213cb262021-08-07 19:21:33 -050042EXTRA_OECONF:append:libc-musl:powerpc64le = " --disable-cpu-profiler --disable-heap-profiler --disable-heap-checker"
Andrew Geissler82c905d2020-04-13 13:39:40 -050043PACKAGECONFIG ?= "libunwind static"
Patrick Williams213cb262021-08-07 19:21:33 -050044PACKAGECONFIG:remove:arm:libc-musl = "libunwind"
45PACKAGECONFIG:remove:riscv64 = "libunwind"
46PACKAGECONFIG:remove:riscv32 = "libunwind"
Andrew Geissler82c905d2020-04-13 13:39:40 -050047
48PACKAGECONFIG[libunwind] = "--enable-libunwind,--disable-libunwind,libunwind"
49PACKAGECONFIG[static] = "--enable-static,--disable-static,"
50
51PACKAGE_BEFORE_PN += "libtcmalloc-minimal"
Patrick Williams213cb262021-08-07 19:21:33 -050052FILES:libtcmalloc-minimal = "${libdir}/libtcmalloc_minimal*${SOLIBS} ${libdir}/libtcmalloc_minimal_debug*${SOLIBS}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050053
54# pprof tool requires Getopt::long and POSIX perl5 modules.
55# Also runs `objdump` on each cpuprofile data file
Patrick Williams213cb262021-08-07 19:21:33 -050056RDEPENDS:${PN} += " \
Andrew Geissler32b11992021-03-31 13:37:05 -050057 binutils \
58 curl \
59 perl-module-carp \
60 perl-module-cwd \
61 perl-module-getopt-long \
62 perl-module-overloading \
63 perl-module-posix \
64"
Andrew Geissler82c905d2020-04-13 13:39:40 -050065
Patrick Williams213cb262021-08-07 19:21:33 -050066RDEPENDS:${PN} += "libtcmalloc-minimal (= ${EXTENDPKGV})"