blob: b94bdad3a7734f4e696b8e95c9a29f82f0ae85d1 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Administration program for the grsecurity RBAC syste"
2DESCRIPTION = "\
3gradm is the userspace RBAC parsing and authentication program for \
4grsecurity grsecurity aims to be a complete security system. gradm \
5performs several tasks for the RBAC system including authenticated \
6via a password to the kernel and parsing rules to be passed to the \
7kernel"
8HOMEPAGE = "http://grsecurity.net/index.php"
9SECTION = "admin"
10LICENSE = "GPL-2.0"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=4641e94ec96f98fabc56ff9cc48be14b"
12DEPENDS = "flex-native bison-native ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
13
Brad Bishop26bdd442019-08-16 17:08:17 -040014SRC_URI = "http://grsecurity.net/stable/${BP}.tar.gz \
Brad Bishop7f28bc52017-12-03 23:42:40 -050015 file://0001-Makefile-remove-strip.patch \
16 file://0001-Makefile-Append-instead-of-overriding-LDFLAGS.patch \
17 "
Brad Bishop26bdd442019-08-16 17:08:17 -040018SRC_URI[md5sum] = "5099c715433981d5a3eed8ded7c5bbc0"
19SRC_URI[sha256sum] = "d3a0b6383ff97a2054941d71133c737efae66afdd8eef59346c031ae15c75ff3"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050020
21S = "${WORKDIR}/gradm"
22
23inherit autotools-brokensep
24
25do_compile() {
26 oe_runmake 'CC=${CC}' \
Brad Bishop26bdd442019-08-16 17:08:17 -040027 'LIBS=' \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050028 'OPT_FLAGS=${CFLAGS}' \
29 'LLEX=${STAGING_BINDIR_NATIVE}/lex' \
30 'FLEX=${STAGING_BINDIR_NATIVE}/flex' \
31 'BISON=${STAGING_BINDIR_NATIVE}/bison' \
32 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', ' ', 'nopam', d)}
33}
34
35do_install() {
36 oe_runmake 'CC=${CC}' \
37 'DESTDIR=${D}' \
Brad Bishop26bdd442019-08-16 17:08:17 -040038 'LIBS=' \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050039 'LLEX=${STAGING_BINDIR_NATIVE}/lex' \
40 'FLEX=${STAGING_BINDIR_NATIVE}/flex' \
41 'BISON=${STAGING_BINDIR_NATIVE}/bison' \
42 install
43
44 # The device nodes are generated by postinstall or udev
45 rm -rf ${D}/dev
46}
47
Patrick Williams213cb262021-08-07 19:21:33 -050048pkg_postinst_ontarget:${PN}() {
Patrick Williamsb48b7b42016-08-17 15:04:38 -050049 /bin/mknod -m 0622 /dev/grsec c 1 13
50}