blob: 2e8ecbfc44e0edcfd3007df84f92351f966522aa [file] [log] [blame]
Brad Bishop0f291cc2019-09-01 15:16:57 -04001DESCRIPTION = "Tiny XML Library"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
4HOMEPAGE = "https://www.msweet.org/mxml/"
5BUGTRACKER = "https://github.com/michaelrsweet/mxml/issues"
6
William A. Kennington IIIb95905d2021-06-02 12:40:56 -07007SRC_URI = "git://github.com/michaelrsweet/mxml.git;nobranch=1"
8SRCREV = "38b044ed8ca2a611ed9ed3e26c4b46416335194e"
Brad Bishop0f291cc2019-09-01 15:16:57 -04009S = "${WORKDIR}/git"
10
11inherit autotools
12
13PACKAGECONFIG ??= "threads"
14PACKAGECONFIG[threads] = "--enable-threads,--disable-threads"
15
16# Package does not support out of tree builds.
17B = "${S}"
18
19# MXML uses autotools but it explicitly states it does not support autoheader.
20EXTRA_AUTORECONF = "--exclude=autopoint,autoheader"
21
Patrick Williams213cb262021-08-07 19:21:33 -050022do_configure:prepend() {
Brad Bishop0f291cc2019-09-01 15:16:57 -040023 # Respect optimization CFLAGS specified by OE.
24 sed -e 's/-Os -g//' -i ${S}/configure.ac
25
26 # Enable verbose compilation output. This is required for extra QA checks to work.
27 sed -e '/.SILENT:/d' -i ${S}/Makefile.in
28}
29
30do_install() {
31 # Package uses DSTROOT instread of standard DESTDIR to specify install location.
32 oe_runmake install DSTROOT=${D}
33}