blob: 7a903e5d4a1dcdcba832429760b991a1509275b4 [file] [log] [blame]
Andrew Geisslerd688a012020-09-18 13:36:00 -05001SUMMARY = "This is the io_uring library, liburing."
2DESCRIPTION = "liburing provides helpers to setup and teardown io_uring \
3instances, and also a simplified interface for applications that don't need \
4(or want) to deal with the full kernel side implementation."
5HOMEPAGE = "https://github.com/axboe/liburing"
6BUGTRACKER = "https://github.com/axboe/liburing/issues"
7SECTION = "libs"
8
9LICENSE = "LGPLv2.1 | MIT"
10LIC_FILES_CHKSUM = "file://README;beginline=41;endline=44;md5=d51b5805e2a675685e6a66ca50904cf9"
11
Andrew Geissler4b7c1152020-11-30 19:55:29 -060012SRC_URI = "git://github.com/axboe/liburing.git;branch=master;protocol=https \
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070013 file://0001-examples-ucontext-cp.c-Do-not-use-SIGSTKSZ.patch \
14 file://0001-tests-fix-portability-issue-when-using-__NR_mmap-sys.patch \
Andrew Geissler4b7c1152020-11-30 19:55:29 -060015 "
Patrick Williams213cb262021-08-07 19:21:33 -050016SRC_URI:append:libc-musl:riscv64 = " file://0001-do-not-build-examples.patch "
17SRC_URI:append:libc-musl:riscv32 = " file://0001-do-not-build-examples.patch "
Andrew Geissler97771a32021-03-05 15:23:11 -060018
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070019SRCREV = "b013dfd5a5f65116373d5e0f0bdfb73db9d8816e"
Andrew Geisslerd688a012020-09-18 13:36:00 -050020S = "${WORKDIR}/git"
21
Patrick Williams213cb262021-08-07 19:21:33 -050022DEPENDS:append:libc-musl = " libucontext"
Andrew Geisslerd688a012020-09-18 13:36:00 -050023XCFLAGS = "-pthread"
Patrick Williams213cb262021-08-07 19:21:33 -050024XCFLAGS:append:libc-musl = " -lucontext"
Andrew Geisslerd688a012020-09-18 13:36:00 -050025
26EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR' 'LDFLAGS=${LDFLAGS}' 'XCFLAGS=${XCFLAGS}' 'BUILDDIR=${S}'"
Andrew Geissler97771a32021-03-05 15:23:11 -060027do_configure() {
28 ${S}/configure --prefix=${prefix}
29}
Andrew Geisslerd688a012020-09-18 13:36:00 -050030do_install () {
31 oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} INCLUDEDIR=${includedir}
32}