blob: 328f7c99ba78b8757918ac5e8fe75c1fad283aed [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001#
2# Copyright (C) 2012 Wind River Systems, Inc.
3#
4SUMMARY = "MCE test suite"
5
6DESCRIPTION = "The MCE test suite is a collection of tools and test scripts for \
7testing the Linux RAS related features, including CPU/Memory error \
8containment and recovery, ACPI/APEI support etc."
9
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
12
13SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mce-test.git;protocol=git \
14 file://makefile-remove-ldflags.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050015 file://0001-gcov_merge.py-scov_merge.py-switch-to-python3.patch \
Brad Bishop19323692019-04-05 15:28:33 -040016 "
Brad Bishop2f973922019-11-11 07:58:48 -050017SRCREV = "7643baf6c3919b3d727e6ba6c2e545dc6a653307"
18PV = "20190917+git${SRCPV}"
Brad Bishop19323692019-04-05 15:28:33 -040019
Patrick Williams213cb262021-08-07 19:21:33 -050020RDEPENDS:${PN} = "mcelog mce-inject dialog bash"
Brad Bishop19323692019-04-05 15:28:33 -040021
22COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
23
24S ="${WORKDIR}/git"
25
Patrick Williams213cb262021-08-07 19:21:33 -050026do_install:append(){
Brad Bishop19323692019-04-05 15:28:33 -040027 install -d ${D}/opt/mce-test
28 cp -rf ${S}/* ${D}/opt/mce-test/
29}
30
Patrick Williams213cb262021-08-07 19:21:33 -050031FILES:${PN} += "/opt"