blob: 1a82495282398b0bec199cd2e2c209efd0777d03 [file] [log] [blame]
Brad Bishop15ae2502019-06-18 21:44:24 -04001SUMMARY = "Skype protocol plug-in for libpurple"
2SECTION = "webos/services"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://skypeweb/gpl3.txt;md5=d90260d32cef39f3c8d6c0f05d3adb8e"
5
6DEPENDS = "pidgin json-glib glib-2.0 zlib"
7
8inherit pkgconfig
9
10SRC_URI = "git://github.com/EionRobb/skype4pidgin;branch=master;protocol=git"
Andrew Geisslerd688a012020-09-18 13:36:00 -050011SRCREV = "b226d1c457d73900ae89b8a7469247fbe33677a6"
Brad Bishop15ae2502019-06-18 21:44:24 -040012
13S = "${WORKDIR}/git"
Andrew Geisslerd688a012020-09-18 13:36:00 -050014PV = "1.7+git${SRCPV}"
Brad Bishop15ae2502019-06-18 21:44:24 -040015
16do_compile() {
17 oe_runmake -C skypeweb;
18}
19
20do_install() {
21 oe_runmake -C skypeweb DESTDIR="${D}" install;
22}
23
Patrick Williams213cb262021-08-07 19:21:33 -050024FILES:${PN} += " \
Brad Bishop15ae2502019-06-18 21:44:24 -040025 ${libdir} \
26"