blob: ee7c140b3cff7af8903a1385fd6996b8c1ca3b1f [file] [log] [blame]
Andrew Geissler97771a32021-03-05 15:23:11 -06001DESCRIPTION = "Google gRPC tools"
2HOMEPAGE = "http://www.grpc.io/"
3SECTION = "devel/python"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515"
7
8inherit pypi setuptools3
9
10DEPENDS += "${PYTHON_PN}-grpcio"
11
12SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch"
13
Andrew Geissler69721092021-07-23 12:57:00 -040014SRC_URI[sha256sum] = "cd85f58038b92e1961f8127d79691e84e151390d35cae73c4c0cbe2042f76b77"
Andrew Geissler97771a32021-03-05 15:23:11 -060015
Patrick Williams213cb262021-08-07 19:21:33 -050016RDEPENDS:${PN} = "${PYTHON_PN}-grpcio"
Andrew Geissler97771a32021-03-05 15:23:11 -060017
18BBCLASSEXTEND = "native nativesdk"
Andrew Geissler32b11992021-03-31 13:37:05 -050019
20# Needs abseil-cpp which does not build for ppc64le/musl
Patrick Williams213cb262021-08-07 19:21:33 -050021COMPATIBLE_HOST:libc-musl:powerpc64le = "null"
Andrew Geissler32b11992021-03-31 13:37:05 -050022