blob: 348af6ec9fca1d19185ef216f6fe04e0a815f1aa [file] [log] [blame]
Andrew Geisslerd221e032020-07-10 16:13:21 -05001SUMMARY = "Seamless operability between C++11 and Python"
2HOMEPAGE = "https://github.com/wjakob/pybind11"
3LICENSE = "BSD-2-Clause"
Andrew Geisslerac970dd2021-02-12 15:32:45 -06004LIC_FILES_CHKSUM = "file://LICENSE;md5=774f65abd8a7fe3124be2cdf766cd06f"
Andrew Geisslerd221e032020-07-10 16:13:21 -05005
Andrew Geissler748a4832020-07-24 16:24:21 -05006DEPENDS = "boost"
Andrew Geisslerd221e032020-07-10 16:13:21 -05007
Andrew Geissler748a4832020-07-24 16:24:21 -05008SRC_URI = "git://github.com/pybind/pybind11.git \
9 file://0001-Do-not-strip-binaries.patch \
10 file://0001-Do-not-check-pointer-size-when-cross-compiling.patch \
Andrew Geisslerac970dd2021-02-12 15:32:45 -060011"
Patrick Williams213cb262021-08-07 19:21:33 -050012SRCREV = "65e95ea8675ea34bdd566d6461330f25c651e5a8"
Andrew Geissler748a4832020-07-24 16:24:21 -050013
14S = "${WORKDIR}/git"
15
16BBCLASSEXTEND = "native"
17
18EXTRA_OECMAKE = "-DPYBIND11_TEST=OFF"
19
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050020inherit cmake setuptools3 python3native
21
22do_configure() {
23 cmake_do_configure
24}
25
26do_compile() {
27 distutils3_do_compile
28 cmake_do_compile
29}
30
31do_install() {
32 distutils3_do_install
33 cmake_do_install
34}
Andrew Geisslera2681d92020-10-16 10:17:07 -050035
36BBCLASSEXTEND = "native nativesdk"