blob: f89c206dd5b3f2d66eed205e82e4c337bd26a255 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Supervisor: A Process Control System"
2DESCRIPTION = "\
3Supervisor is a client/server system that allows its users \
4to monitorand control a number of processes on UNIX-like \
5operating systems."
6HOMEPAGE = "https://github.com/Supervisor/supervisor"
7LICENSE = "BSD-4-Clause"
8LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=5b4e3a2172bba4c47cded5885e7e507e"
9
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050010SRC_URI[sha256sum] = "5b2b8882ec8a3c3733cce6965cc098b6d80b417f21229ab90b18fe551d619f90"
Andrew Geissler82c905d2020-04-13 13:39:40 -050011
12PYPI_PACKAGE = "supervisor"
13inherit pypi systemd setuptools3
Patrick Williams213cb262021-08-07 19:21:33 -050014RDEPENDS:${PN} = "\
Andrew Geissler82c905d2020-04-13 13:39:40 -050015 ${PYTHON_PN}-meld3 \
16"
17
18SRC_URI += "file://supervisord.conf \
19 file://supervisor.service \
20 "
Patrick Williams213cb262021-08-07 19:21:33 -050021SYSTEMD_SERVICE:${PN} = "supervisor.service"
Andrew Geissler82c905d2020-04-13 13:39:40 -050022
Patrick Williams213cb262021-08-07 19:21:33 -050023do_install:append() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050024 install -d ${D}${sysconfdir}/supervisor
25 install -d ${D}${systemd_system_unitdir}
26
27 install -m 0644 ${WORKDIR}/supervisord.conf ${D}${sysconfdir}/supervisor
28 install -m 0644 ${WORKDIR}/supervisor.service ${D}${systemd_system_unitdir}
29}