blob: 499fb370498addebc9adba0b4e8a939936582d70 [file] [log] [blame]
Andrew Geisslerd688a012020-09-18 13:36:00 -05001SUMMARY = "Python interface for libsystemd"
2HOMEPAGE = "https://github.com/systemd/python-systemd"
3LICENSE = "LGPLv2.1+"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4fbd65380cdd255951079008b364516c"
5
6PYPI_PACKAGE = "systemd-python"
7DEPENDS += "systemd (<=234)"
Patrick Williams213cb262021-08-07 19:21:33 -05008RDEPENDS:${PN} += "systemd ${PYTHON_PN}-syslog ${PYTHON_PN}-logging python3-syslog"
Andrew Geisslerd688a012020-09-18 13:36:00 -05009REQUIRED_DISTRO_FEATURES = "systemd"
10inherit pypi features_check setuptools3
11
12SRC_URI[md5sum] = "5071ea5bcb976186e92a3f5e75df221d"
13SRC_URI[sha256sum] = "fd0e44bf70eadae45aadc292cb0a7eb5b0b6372cd1b391228047d33895db83e7"
14
15# allow for common patches for python- and python3-systemd
Patrick Williams213cb262021-08-07 19:21:33 -050016FILESEXTRAPATHS:prepend := "${THISDIR}/python-systemd:"
Andrew Geisslerd688a012020-09-18 13:36:00 -050017
18SRC_URI += "file://endian.patch"
19
Patrick Williams213cb262021-08-07 19:21:33 -050020SRC_URI:append:libc-musl = " file://0001-Provide-implementation-of-strndupa-for-musl.patch"