blob: 7f212ddd87b6b3c82ccb64944f43cbe47d61d207 [file] [log] [blame]
Brad Bishop072e2382019-09-25 08:16:16 -04001SUMMARY = "Generator is a helper for generating test methods for nose while still using unittest."
2DESCRIPTION = "Python package with modified subclasses of all stdlib XML \
3parsers that prevent any potentially malicious operation."
4
5LICENSE = "ISC"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=041a2bff595d40ccb4b36356f89dab00"
7
Andrew Geisslerd688a012020-09-18 13:36:00 -05008SRC_URI += " \
9 file://run-ptest \
10"
11
Brad Bishop072e2382019-09-25 08:16:16 -040012SRC_URI[md5sum] = "6c69e73ba5b4b3ed62f7bcda071c64f1"
13SRC_URI[sha256sum] = "ad5925c814bfe79497b43df096e3bb52c166d1577f7aff160137301676232f4a"
14
Andrew Geisslerd688a012020-09-18 13:36:00 -050015inherit pypi setuptools3 ptest
16
Patrick Williams213cb262021-08-07 19:21:33 -050017RDEPENDS:${PN}-ptest += " \
Andrew Geisslerd688a012020-09-18 13:36:00 -050018 ${PYTHON_PN}-pytest \
19 ${PYTHON_PN}-mock \
20"
21
22do_install_ptest() {
23 install -d ${D}${PTEST_PATH}/tests
24 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
25}
Brad Bishop072e2382019-09-25 08:16:16 -040026
27DEPENDS += "python3-nose-native"
28
Patrick Williams213cb262021-08-07 19:21:33 -050029RDEPENDS:${PN} += "python3-six"