blob: 1dedc5102977994f11799685f365aee15838f0f6 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Tornado is an open source version of the scalable, non-blocking web server and tools that power FriendFeed."
2DESCRIPTION = "Tornado is a Python web framework and asynchronous networking library, originally developed at FriendFeed. \
3By using non-blocking network I/O, Tornado can scale to tens of thousands of open connections, making it ideal for long \
4polling, WebSockets, and other applications that require a long-lived connection to each user."
5HOMEPAGE = "http://www.tornadoweb.org/en/stable/"
6LICENSE = "Apache-2.0"
Andrew Geissler4b7c1152020-11-30 19:55:29 -06007LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05008
Andrew Geissler4b7c1152020-11-30 19:55:29 -06009SRC_URI[md5sum] = "f324f5e7607798552359d6ab054c4321"
10SRC_URI[sha256sum] = "33c6e81d7bd55b468d2e793517c909b139960b6c790a60b7991b9b6b76fb9791"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050011
Andrew Geissler89770b02020-06-13 10:40:47 -050012inherit pypi setuptools3
13
14# Requires _compression which is currently located in misc
Patrick Williams213cb262021-08-07 19:21:33 -050015RDEPENDS:${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-numbers ${PYTHON_PN}-email \
Brad Bishop316dfdd2018-06-25 12:45:53 -040016 ${PYTHON_PN}-pkgutil ${PYTHON_PN}-html ${PYTHON_PN}-json ${PYTHON_PN}-certifi ${PYTHON_PN}-threading \
Andrew Geissler89770b02020-06-13 10:40:47 -050017 ${PYTHON_PN}-ctypes ${PYTHON_PN}-misc"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050018
Patrick Williams213cb262021-08-07 19:21:33 -050019RDEPENDS:${PN}-test += "${PN} ${PYTHON_PN}-unittest"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050020
21PACKAGES =+ "\
22 ${PN}-test \
23"
24
Patrick Williams213cb262021-08-07 19:21:33 -050025FILES:${PN}-test = " \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050026 ${libdir}/${PYTHON_DIR}/site-packages/*/test \
27 ${libdir}/${PYTHON_DIR}/site-packages/*/testing.py* \
28"